scheme_package 0.0.2

  • Readme
  • Changelog
  • Installing
  • 43

scheme_package #

Scheme Library - Tools and Widgets.

Installation #

Add this to your pubspec.yml dependencies:

scheme_package: "^0.0.1-dev.1"

## Coming Soon!

[0.0.2] - Fixed Exports #

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  scheme_package: ^0.0.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:scheme_package/scheme_package.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
96
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
43
Learn more about scoring.

We analyzed this package on Apr 7, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6
  • Flutter: 1.12.13+hotfix.8

Health suggestions

Fix lib/src/ui/styles.dart. (-2.96 points)

Analysis of lib/src/ui/styles.dart reported 6 hints, including:

line 10 col 10: The declaration '_thin' isn't referenced.

line 11 col 10: The declaration '_extraLight' isn't referenced.

line 15 col 9: The declaration '_semiBold' isn't referenced.

line 16 col 9: The declaration '_bold' isn't referenced.

line 17 col 9: The declaration '_extraBold' isn't referenced.

Fix lib/src/utils/text_scale.dart. (-1 points)

Analysis of lib/src/utils/text_scale.dart reported 2 hints:

line 41 col 8: This function has a return type of 'double', but doesn't end with a return statement.

line 42 col 6: Equality operator == invocation with references of unrelated types.

Fix lib/src/global_widgets/custom_image.dart. (-0.50 points)

Analysis of lib/src/global_widgets/custom_image.dart reported 1 hint:

line 2 col 8: Unused import: 'package:scheme_package/src/utils/constants.dart'.

Fix additional 19 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/scheme_package.dart (Run flutter format to format lib/scheme_package.dart.)
  • lib/src/decorations/bubble_decoration.dart (Run flutter format to format lib/src/decorations/bubble_decoration.dart.)
  • lib/src/decorations/bubble_view.dart (Run flutter format to format lib/src/decorations/bubble_view.dart.)
  • lib/src/decorations/custom_wave.dart (Run flutter format to format lib/src/decorations/custom_wave.dart.)
  • lib/src/decorations/decoration_positioner.dart (Run flutter format to format lib/src/decorations/decoration_positioner.dart.)
  • lib/src/decorations/logo_decoration.dart (Run flutter format to format lib/src/decorations/logo_decoration.dart.)
  • lib/src/decorations/position_containers.dart (Run flutter format to format lib/src/decorations/position_containers.dart.)
  • lib/src/decorations/superellipse_shape.dart (Run flutter format to format lib/src/decorations/superellipse_shape.dart.)
  • lib/src/global_widgets/auto_size_text.dart (Run flutter format to format lib/src/global_widgets/auto_size_text.dart.)
  • lib/src/global_widgets/custom_app_bar.dart (Run flutter format to format lib/src/global_widgets/custom_app_bar.dart.)
  • lib/src/global_widgets/custom_bottom_bar.dart (Run flutter format to format lib/src/global_widgets/custom_bottom_bar.dart.)
  • lib/src/global_widgets/image_fade.dart (Run flutter format to format lib/src/global_widgets/image_fade.dart.)
  • lib/src/global_widgets/smart_text.dart (Run flutter format to format lib/src/global_widgets/smart_text.dart.)
  • lib/src/parent_views/animated_parent.dart (Run flutter format to format lib/src/parent_views/animated_parent.dart.)
  • lib/src/ui/gradients.dart (Run flutter format to format lib/src/ui/gradients.dart.)
  • lib/src/ui/theme.dart (Run flutter format to format lib/src/ui/theme.dart.)
  • lib/src/utils/color_tools.dart (Run flutter format to format lib/src/utils/color_tools.dart.)
  • lib/src/utils/constants.dart (Run flutter format to format lib/src/utils/constants.dart.)
  • lib/src/utils/scroll_methods.dart (Run flutter format to format lib/src/utils/scroll_methods.dart.)

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (google_fonts).

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and scheme_package.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.6.0 <3.0.0
boxicons_flutter ^1.1.0 1.1.0
color ^2.1.1 2.1.1
flutter 0.0.0
flutter_custom_clippers ^1.1.0 1.1.0
flutter_icons ^1.0.0+1 1.0.0+1
flutter_staggered_animations ^0.1.2 0.1.2
google_fonts ^0.3.7 0.3.10 0.4.0
Transitive dependencies
async 2.4.1
charcode 1.1.3
collection 1.14.11 1.14.12
convert 2.1.1
crypto 2.1.4
http 0.12.0+4
http_parser 3.1.4
meta 1.1.8
path 1.6.4
path_provider 1.6.5
path_provider_macos 0.0.4
path_provider_platform_interface 1.0.1
pedantic 1.9.0
platform 2.2.1
plugin_platform_interface 1.0.2
sky_engine 0.0.99
source_span 1.7.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test