boxicons_flutter 1.1.0

boxicons_flutter #

Use Boxicons in Flutter.

Installation #

In the dependencies: section of your pubspec.yaml, add the following line:

  boxicons_flutter: <latest_version>

Usage #

import 'package:boxicons_flutter/boxicons_flutter.dart';

class MyWidget extends StatelessWidget {
  Widget build(BuildContext context) {
    return new IconButton(
      // Use the Boxicons class for the IconData
      icon: new Icon(Boxicons.bxBolt),
      onPressed: () { print("Pressed"); }
     );
  }
}

[1.0.0]

First release.

[1.1.0]

Add example and update description.

example/README.md

boxicons_flutter_example #

Example of using boxicons_flutter.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  boxicons_flutter: ^1.1.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:boxicons_flutter/boxicons_flutter.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
71
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
76
Overall:
Weighted score of the above. [more]
80
Learn more about scoring.

We analyzed this package on Feb 19, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.5
  • Flutter: 1.12.13+hotfix.7

Health issues and suggestions

Document public APIs. (-1 points)

825 out of 825 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Format lib/boxicons_flutter.dart.

Run flutter format to format lib/boxicons_flutter.dart.

Maintenance suggestions

Package is getting outdated. (-23.84 points)

The package was last published 64 weeks ago.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8