sacco 0.2.0 copy "sacco: ^0.2.0" to clipboard
sacco: ^0.2.0 copied to clipboard

Pure Dart library allowing you to easily create an HD Wallet and create, sign and send Cosmos-SDK transactions.

5
likes
120/ 140
pub points
55%
popularity

We analyzed this package 2 days ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

95 out of 226 API elements (42.0 %) have documentation comments.

Some symbols that are missing documentation: account_data, account_data.AccountData, account_data.AccountData.AccountData, account_data.AccountData.accountNumber, account_data.AccountData.coins.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 7 issues. Showing the first 2:

INFO: The import of 'utils/map_sorter.dart' is unnecessary because all of the used elements are also provided by the import of 'package:sacco/sacco.dart'.

lib/tx_signer.dart:8:8

  ╷
8 │ import 'utils/map_sorter.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/tx_signer.dart

INFO: The variable name '_ZERO32' isn't a lowerCamelCase identifier.

lib/utils/bip32.dart:228:16

    ╷
228 │   static final _ZERO32 = Uint8List.fromList(List.generate(32, (index) => 0));
    │                ^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/utils/bip32.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
bech32 >=0.2.0 <0.3.0 0.2.2 0.2.2
convert >=2.0.0 <4.0.0 3.1.1 3.1.1
equatable >=2.0.0 <3.0.0 2.0.5 2.0.5
http >=0.13.0 <0.14.0 0.13.6 1.2.1
pointycastle ^3.0.0-nullsafety.2 3.7.4 3.7.4
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
collection - 1.18.0 1.18.0
http_parser - 4.0.2 4.0.2
js - 0.7.1 0.7.1
meta - 1.12.0 1.12.0
path - 1.9.0 1.9.0
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=0.13.0 <0.14.0` on http does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Dart 3.3.0.

Check the analysis log for details.

5
likes
120
pub points
55%
popularity

Publisher

verified publishercommercio.network

Pure Dart library allowing you to easily create an HD Wallet and create, sign and send Cosmos-SDK transactions.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

bech32, convert, equatable, http, pointycastle

More

Packages that depend on sacco