sa_v1_migration 1.1.2
sa_v1_migration: ^1.1.2

Flutter Android iOS web

Migration Guide (Use simple_animation v1 code while migratating to v2)

1
likes
100 / 110
pub points
98 %
popularity

We analyzed this package on Nov 26, 2020, and awarded it 100 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/example.md

10/10 points: 20% or more of the public API has dartdoc comments

  • 116 out of 165 API elements (70.3 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 13 issues. Showing the first 2:

INFO: 'AnimationControllerX' is deprecated and shouldn't be used. See migration guide: https://pub.dev/packages/sa_v1_migration.

lib/simple_animations/animation_controller_x/animation_controller_x.dart:191:30

    ╷
191 │ /// Type of status event of [AnimationControllerX].
    │                              ^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/simple_animations/animation_controller_x/animation_controller_x.dart

INFO: 'AnimationTask' is deprecated and shouldn't be used. See migration guide: https://pub.dev/packages/sa_v1_migration.

lib/simple_animations/animation_controller_x/animation_controller_x.dart:201:40

    ╷
201 │     AnimationControllerXStatus status, AnimationTask task);
    │                                        ^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/simple_animations/animation_controller_x/animation_controller_x.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

No dependencies.

Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
meta-1.3.0-nullsafety.61.3.0-nullsafety.6
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

1
likes
100
pub points
98%
popularity

Publisher

felix-blaschke.de

Migration Guide (Use simple_animation v1 code while migratating to v2)

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on sa_v1_migration