rx_cubit 0.0.1 copy "rx_cubit: ^0.0.1" to clipboard
rx_cubit: ^0.0.1 copied to clipboard

An adaption of the Cubit class using RxDart and Change Notifier.

130/ 160
pub points

We analyzed this package 37 hours ago, and awarded it 130 pub points (of a possible 160):

Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: rx_cubit,
    • contains a version property, and,
    • does not contain a publish_to property.

pubspec.yaml from the repository has no repository or homepage URL.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

6 out of 10 API elements (60.0 %) have documentation comments.

Some symbols that are missing documentation: rx_cubit, rx_cubit.RxCubit.state, rx_cubit.RxCubit.stream, rx_cubit_testing_extension.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
rxdart ^0.27.3 0.27.7 0.28.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.27.3` on rxdart does not support the stable version `0.28.0`.

Try running dart pub upgrade --major-versions rxdart to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.9, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

pub points


verified publishernonvanilla.shop

An adaption of the Cubit class using RxDart and Change Notifier.

Repository (GitHub)
View/report issues


API reference


BSD-3-Clause (license)


flutter, rxdart


Packages that depend on rx_cubit