runevm_fl 0.3.1 copy "runevm_fl: ^0.3.1" to clipboard
runevm_fl: ^0.3.1 copied to clipboard

Rune Bindings and Forge deployment for Flutter Containerization for TinyML/Mobile Applications on Tiny/Mobile devices.

4
likes
120/ 160
pub points
0%
popularity

We analyzed this package 16 hours ago, and awarded it 120 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected licenses: Apache-2.0, MIT.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

2 out of 38 API elements (5.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

To highlight public API members missing documentation consider enabling the public_member_api_docs lint.

Some symbols that are missing documentation: backend, backend.Backend, backend.Backend.Backend, backend.Backend.apiKey, backend.Backend.baseURL.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Web

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:runevm_fl/runevm_fl.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Linux`.

Because:

  • package:runevm_fl/runevm_fl.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `macOS`.

Because:

  • package:runevm_fl/runevm_fl.dart that declares support for platforms: Android, iOS, Web.

These issues are present but do not affect the score, because they may not originate in your package:

Package not compatible with platform Web

Because:

  • package:runevm_fl/runevm_fl.dart that imports:
  • dart:io
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 6 issues. Showing the first 2:

WARNING: Unused import: 'dart:convert'.

lib/backend/backend.dart:1:8

  ╷
1 │ import 'dart:convert';
  │        ^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/backend/backend.dart

WARNING: Unused import: 'dart:convert'.

lib/runevm_fl_web.dart:2:8

  ╷
2 │ import 'dart:convert';
  │        ^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/runevm_fl_web.dart

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
flutter_web_plugins flutter 0.0.0 0.0.0
http ^0.13.4 0.13.6 1.2.1
inject_js ^2.0.0 2.0.0 2.0.0
js ^0.6.3 0.6.7 0.7.1
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
http_parser - 4.0.2 4.0.2
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.13.4` on http does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

The constraint `^0.6.3` on js does not support the stable version `0.7.0`.

Try running dart pub upgrade --major-versions js to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

4
likes
120
pub points
0%
popularity

Publisher

verified publisherhotg.ai

Rune Bindings and Forge deployment for Flutter Containerization for TinyML/Mobile Applications on Tiny/Mobile devices.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0, MIT (LICENSE)

Dependencies

flutter, flutter_web_plugins, http, inject_js, js

More

Packages that depend on runevm_fl