rounded_loading_button_gradient 0.1.1
rounded_loading_button_gradient: ^0.1.1 copied to clipboard

A new Flutter package. Helping developers to build UI quickly, I try to build on existing widgets and make them useful and beautiful.

3
likes
110/ 130
pub points
11%
popularity

We analyzed this package on Oct 25, 2021, and awarded it 110 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 31 out of 57 API elements (54.4 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package not compatible with runtime flutter-web on Web

Because:

  • package:rounded_loading_button_gradient/rounded_loading_button_gradient.dart that imports:
  • package:rounded_loading_button_gradient/src/rounded_loading_button_gradient/rounded_loading_button_gradient_widget.dart that imports:
  • package:flutter_svg/flutter_svg.dart that imports:
  • package:flutter_svg/svg.dart that imports:
  • package:flutter_svg/src/picture_provider.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/src/rounded_loading_button_gradient/rounded_loading_button_gradient_widget.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
auto_size_text_pk^3.0.03.0.03.0.0
flutterflutter0.0.00.0.0
flutter_svg^0.22.00.22.00.23.0+1
rxdart^0.27.10.27.20.27.2
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
collection-1.15.01.15.0
meta-1.7.01.7.0
path_drawing-0.5.1+10.5.1+1
path_parsing-0.2.10.2.1
petitparser-4.4.04.4.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1
xml-5.3.15.3.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.22.0` on flutter_svg does not support the stable version `0.23.0`, that was published 12 days ago.

When flutter_svg is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions flutter_svg to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.

3
likes
110
pub points
11%
popularity

A new Flutter package. Helping developers to build UI quickly, I try to build on existing widgets and make them useful and beautiful.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

auto_size_text_pk, flutter, flutter_svg, rxdart

More

Packages that depend on rounded_loading_button_gradient