rotation_log 0.0.5 icon indicating copy to clipboard operation
rotation_log: ^0.0.5 copied to clipboard

logging supported rotation files

0
likes
110/ 140
pub points
46%
popularity

We analyzed this package 2 days ago, and awarded it 110 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
20 / 30icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

10/10 points: Package has an example

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 67 API elements (1.5 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS

These platforms are not supported:

Package does not support platform `Web`.

Because:

  • package:rotation_log/rotation_log.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS.
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
archive^3.3.03.3.63.3.6
clock^1.1.01.1.11.1.1
fake_async^1.3.01.3.11.3.1
flutterflutter0.0.00.0.0
intl^0.17.00.17.00.18.0
logger^1.1.01.1.01.1.0
meta^1.7.01.8.01.9.0
path^1.8.01.8.31.8.3
path_provider^2.0.92.0.122.0.12
stack_trace^1.10.01.11.01.11.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.11.2.1
collection-1.17.01.17.1
convert-3.1.13.1.1
crypto-3.0.23.0.2
ffi-2.0.12.0.1
file-6.1.46.1.4
js-0.6.50.6.7
material_color_utilities-0.2.00.2.0
path_provider_android-2.0.222.0.22
path_provider_foundation-2.1.12.1.1
path_provider_linux-2.1.72.1.7
path_provider_platform_interface-2.0.52.0.5
path_provider_windows-2.1.32.1.3
platform-3.1.03.1.0
plugin_platform_interface-2.1.32.1.3
pointycastle-3.6.23.6.2
process-4.2.44.2.4
sky_engine-0.0.990.0.99
typed_data-1.3.11.3.1
vector_math-2.1.42.1.4
win32-3.1.34.1.1
xdg_directories-0.2.0+30.2.0+3

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.17.0` on intl does not support the stable version `0.18.0`.

Try running dart pub upgrade --major-versions intl to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.25, Flutter 3.7.0, Dart 2.19.0.