risecx_chat_client 1.2.3+1
risecx_chat_client: ^1.2.3+1 copied to clipboard

Risecx Company Chat Client

0
likes
70/ 130
pub points
4%
popularity

We analyzed this package on Nov 26, 2021, and awarded it 70 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 38 out of 831 API elements (4.6 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:risecx_chat_client/risecx_chat_client.dart that imports:
  • package:risecx_chat_client/widgets/widgets.dart that imports:
  • package:risecx_chat_client/widgets/chat/chat.dart that imports:
  • package:risecx_chat_client/widgets/chat/message-list.dart that imports:
  • package:risecx_chat_client/widgets/chat/message-list-item.dart that imports:
  • package:risecx_chat_client/widgets/chat/messages_types/messages_types.dart that imports:
  • package:risecx_chat_client/widgets/chat/messages_types/video_message/video_message.dart that imports:
  • package:risecx_chat_client/widgets/chat/messages_types/video_message/video_message_widget.dart that imports:
  • package:risecx_chat_client/widgets/chat/messages_types/video_message/youtube_videos_player_widget.dart that imports:
  • package:youtube_player_flutter/youtube_player_flutter.dart that imports:
  • package:youtube_player_flutter/src/widgets/widgets.dart that imports:
  • package:youtube_player_flutter/src/widgets/touch_shutter.dart that imports:
  • package:youtube_player_flutter/src/utils/youtube_player_controller.dart that imports:
  • package:webview_media/webview_flutter.dart that declares support for platforms: Android, iOS.
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
carousel_slider^1.3.11.4.14.0.0
chewie^0.9.8+10.9.101.2.2
dio^3.0.83.0.104.0.4
flushbar^1.10.41.10.41.10.4
flutterflutter0.0.00.0.0
flutter_webview_plugin^0.3.10+10.3.110.4.0
loading_animations^2.1.02.2.02.2.0
logging^0.11.40.11.41.0.2
photo_view^0.5.00.5.00.13.0
pretty_dio_logger^1.1.11.1.11.1.1
retry^3.0.13.1.03.1.0
rxdart^0.18.00.18.10.27.3
shared_preferences^0.5.6+10.5.12+42.0.9
transparent_image^1.0.01.0.02.0.0
url_launcher^5.1.65.7.106.0.15
video_player^0.10.70.10.12+52.2.7
web_socket_channel^1.1.01.2.02.1.0
websocket_manager^0.2.20.2.20.2.2
youtube_player_flutter^6.0.3+26.1.18.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.22.8.2
characters-1.1.01.2.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
crypto-3.0.13.0.1
ffi-1.1.21.1.2
file-6.1.26.1.2
flutter_web_plugins-0.0.00.0.0
http_parser-3.1.44.0.0
js-0.6.30.6.3
meta-1.7.01.7.0
open_iconic_flutter-0.3.00.3.0
path-1.8.01.8.0
path_provider_linux-0.0.1+22.1.2
path_provider_platform_interface-1.0.42.0.1
path_provider_windows-0.0.52.0.4
platform-3.0.23.0.2
plugin_platform_interface-1.0.32.0.2
process-4.2.44.2.4
shared_preferences_linux-0.0.2+42.0.3
shared_preferences_macos-0.0.1+112.0.2
shared_preferences_platform_interface-1.0.42.0.0
shared_preferences_web-0.1.2+72.0.2
shared_preferences_windows-0.0.2+32.0.3
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
stream_channel-2.1.02.1.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
url_launcher_linux-0.0.1+42.0.2
url_launcher_macos-0.0.1+92.0.2
url_launcher_platform_interface-1.0.92.0.4
url_launcher_web-0.1.5+32.0.4
url_launcher_windows-0.0.1+32.0.2
vector_math-2.1.02.1.1
video_player_platform_interface-2.2.04.2.0
video_player_web-0.1.4+12.0.4
wakelock-0.1.4+20.5.6
webview_media-0.1.20.1.2
win32-2.3.12.3.1
xdg_directories-0.1.20.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 13 issues. Showing the first 2:

The constraint `^1.3.1` on carousel_slider does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions carousel_slider to update the constraint.

The constraint `^0.9.8+1` on chewie does not support the stable version `0.10.0`.

Try running dart pub upgrade --major-versions chewie to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.