risecx_chat_client 1.0.0

  • Readme
  • Changelog
  • Installing
  • new30

risecx_chat_client #

A new Flutter package project.

Getting Started #

This project is a starting point for a Dart package, a library module containing code that can be shared easily across multiple Flutter or Dart projects.

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

[0.0.1] - TODO: Add release date. #

  • TODO: Describe initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  risecx_chat_client: ^1.0.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:risecx_chat_client/risecx_chat_client.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
81
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
30
Overall:
Weighted score of the above. [more]
30
Learn more about scoring.

We analyzed this package on Jul 9, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.14
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform linux

Because:

  • package:risecx_chat_client/risecx_chat_client.dart that imports:
  • package:risecx_chat_client/blocs/blocs.dart that imports:
  • package:risecx_chat_client/blocs/chat_bloc.dart that imports:
  • package:websocket_manager/websocket_manager.dart that declares support for platforms: android, ios

Package does not support Flutter platform macos

Because:

  • package:risecx_chat_client/risecx_chat_client.dart that imports:
  • package:risecx_chat_client/blocs/blocs.dart that imports:
  • package:risecx_chat_client/blocs/chat_bloc.dart that imports:
  • package:websocket_manager/websocket_manager.dart that declares support for platforms: android, ios

Package does not support Flutter platform web

Because:

  • package:risecx_chat_client/risecx_chat_client.dart that imports:
  • package:risecx_chat_client/blocs/blocs.dart that imports:
  • package:risecx_chat_client/blocs/chat_bloc.dart that imports:
  • package:websocket_manager/websocket_manager.dart that declares support for platforms: android, ios

Package does not support Flutter platform windows

Because:

  • package:risecx_chat_client/risecx_chat_client.dart that imports:
  • package:risecx_chat_client/blocs/blocs.dart that imports:
  • package:risecx_chat_client/blocs/chat_bloc.dart that imports:
  • package:websocket_manager/websocket_manager.dart that declares support for platforms: android, ios

Package not compatible with SDK dart

Because:

  • risecx_chat_client that is a package requiring null.

Health suggestions

Fix lib/models/program_model.dart. (-18.98 points)

Analysis of lib/models/program_model.dart reported 42 hints, including:

line 54 col 22: Avoid wrapping fields in getters and setters just to be "safe".

line 55 col 7: Avoid wrapping fields in getters and setters just to be "safe".

line 57 col 12: Avoid wrapping fields in getters and setters just to be "safe".

line 58 col 7: Avoid wrapping fields in getters and setters just to be "safe".

line 59 col 12: Avoid wrapping fields in getters and setters just to be "safe".

Format lib/models/messages/commons/buttons_model.dart.

Run flutter format to format lib/models/messages/commons/buttons_model.dart.

Format lib/models/messages/commons/commons.dart.

Run flutter format to format lib/models/messages/commons/commons.dart.

Fix additional 10 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/models/messages/generic_message_model.dart (Run flutter format to format lib/models/messages/generic_message_model.dart.)
  • lib/models/messages/list_message_model.dart (Run flutter format to format lib/models/messages/list_message_model.dart.)
  • lib/models/messages/send_message_model.dart (Run flutter format to format lib/models/messages/send_message_model.dart.)
  • lib/models/models.dart (Run flutter format to format lib/models/models.dart.)
  • lib/widgets/chat/messages_types/button_message_widget.dart (Run flutter format to format lib/widgets/chat/messages_types/button_message_widget.dart.)
  • lib/widgets/chat/messages_types/image_message_widget.dart (Run flutter format to format lib/widgets/chat/messages_types/image_message_widget.dart.)
  • lib/widgets/chat/messages_types/messages_types.dart (Run flutter format to format lib/widgets/chat/messages_types/messages_types.dart.)
  • lib/widgets/chat/messages_types/quickreply_message_widget.dart (Run flutter format to format lib/widgets/chat/messages_types/quickreply_message_widget.dart.)
  • lib/widgets/chat/messages_types/video_message/video_message_widget.dart (Run flutter format to format lib/widgets/chat/messages_types/video_message/video_message_widget.dart.)
  • lib/widgets/commons/commons.dart (Run flutter format to format lib/widgets/commons/commons.dart.)

Maintenance issues and suggestions

Support latest dependencies. (-40 points)

The version constraint in pubspec.yaml does not support the latest published versions for 4 dependencies (carousel_slider, photo_view, rxdart, youtube_player_flutter).

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and risecx_chat_client.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
carousel_slider ^1.3.1 1.4.1 2.2.1
chewie ^0.9.8+1 0.9.10
dio ^3.0.8 3.0.9
flutter 0.0.0
flutter_webview_plugin ^0.3.10+1 0.3.11
loading_animations ^2.1.0 2.1.0
logging ^0.11.4 0.11.4
photo_view ^0.5.0 0.5.0 0.9.2
rxdart ^0.18.0 0.18.1 0.24.1
shared_preferences ^0.5.6+1 0.5.8
transparent_image ^1.0.0 1.0.0
url_launcher ^5.1.6 5.5.0
video_player ^0.10.7 0.10.11+2
websocket_manager ^0.2.1 0.2.2
youtube_player_flutter ^6.0.3+2 6.1.1 7.0.0+6
Transitive dependencies
charcode 1.1.3
collection 1.14.12 1.14.13
file 5.2.1
flutter_web_plugins 0.0.0
http_parser 3.1.4
intl 0.16.1
meta 1.1.8 1.2.2
open_iconic_flutter 0.3.0
path 1.7.0
path_provider_linux 0.0.1+2
path_provider_platform_interface 1.0.2
platform 2.2.1
platform_detect 1.4.0
plugin_platform_interface 1.0.2
process 3.0.13
pub_semver 1.4.4
shared_preferences_linux 0.0.2+1
shared_preferences_macos 0.0.1+10
shared_preferences_platform_interface 1.0.4
shared_preferences_web 0.1.2+7
sky_engine 0.0.99
source_span 1.7.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6 1.2.0
url_launcher_linux 0.0.1+1
url_launcher_macos 0.0.1+7
url_launcher_platform_interface 1.0.7
url_launcher_web 0.1.2
vector_math 2.0.8 2.1.0-nullsafety
video_player_platform_interface 2.0.2
video_player_web 0.1.3+2
wakelock 0.1.4+2
webview_media 0.1.2
xdg_directories 0.1.0
Dev dependencies
flutter_test