rikulo_commons 5.0.4
rikulo_commons: ^5.0.4 copied to clipboard

Common reusable Dart classes and utilities.

1
likes
80/ 130
pub points
89%
popularity

We analyzed this package on Sep 16, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 255 out of 335 API elements (76.1 %) have documentation comments.
Support multiple platforms
0 / 20

0/20 points: Supports 0 of 2 possible platforms (native, js)

SDK issues found:

Package is not compatible with the Dart SDK.

Because it is not compatible with any of the supported runtimes: native-aot, native, js.

Package is not compatible with Dart SDK using runtime native-aot. Because:

  • package:rikulo_commons/html.dart that imports:
  • dart:html

Package is not compatible with Dart SDK using runtime native. Because:

  • package:rikulo_commons/html.dart that imports:
  • dart:html

Package is not compatible with Dart SDK using runtime js. Because:

  • package:rikulo_commons/convert.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 24 issues. Showing the first 2:

lib/browser.dart doesn't match the Dart formatter.

To format your files run: dart format .

lib/convert.dart doesn't match the Dart formatter.

To format your files run: dart format .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
charcodeany1.3.11.3.1
loggingany1.0.21.0.2
mimeany1.0.01.0.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.1+1, Dart 2.14.1.

1
likes
80
pub points
89%
popularity

Common reusable Dart classes and utilities.

Repository (GitHub)
View/report issues

Documentation

API reference

License

unknown (LICENSE)

Dependencies

charcode, logging, mime

More

Packages that depend on rikulo_commons