retrofit_generator 1.4.1+2
retrofit_generator: ^1.4.1+2 copied to clipboard

Dart native

retrofit generator is an dio client generator using source_gen and inspired by Chopper and Retrofit.

9
likes
75 / 110
pub points
92 %
popularity

We analyzed this package on Mar 2, 2021, and awarded it 75 pub points (of a possible 110):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:1:8

  ╷
1 │ <p>See <a href="http://mings.in/retrofit.dart/">retrofit.dart</a></p>
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/example.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 2 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:retrofit_generator/retrofit_generator.dart that imports:
  • package:retrofit_generator/src/generator.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/utils.dart that imports:
  • package:build/build.dart that imports:
  • package:build/src/generate/run_post_process_builder.dart that imports:
  • package:build/src/builder/post_process_builder.dart that imports:
  • package:build/src/builder/builder.dart that imports:
  • package:build/src/builder/build_step.dart that imports:
  • package:build/src/asset/reader.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:glob/src/io.dart that imports:
  • package:glob/src/io_export.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 11 issues. Showing the first 2:

INFO: DO use curly braces for all flow control structures.

lib/src/generator.dart:382:7

    ╷
382 │       namedArguments[_cancelToken] = refer(cancelToken.item1.displayName);
    │       ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/generator.dart

INFO: DO use curly braces for all flow control structures.

lib/src/generator.dart:386:7

    ╷
386 │       namedArguments[_onSendProgress] = refer(sendProgress.item1.displayName);
    │       ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/generator.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzerany0.41.21.1.0
build^1.2.21.6.21.6.3
built_collection^4.2.04.3.25.0.0
code_builder^3.2.03.6.03.6.0
dart_style^1.0.01.3.121.3.14
dio^3.0.13.0.103.0.10
retrofit^1.3.4+11.3.4+11.3.4+1
source_gen^0.9.4+20.9.10+30.9.10+3
tuple^1.0.21.0.31.0.3
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-14.0.017.0.0
args-1.6.02.0.0
async-2.4.22.5.0
built_value-7.1.08.0.0
charcode-1.1.31.2.0
cli_util-0.2.00.3.0
collection-1.14.131.15.0
convert-2.1.13.0.0
crypto-2.1.53.0.0
file-5.2.16.1.0
fixnum-0.10.111.0.0
glob-1.2.02.0.0
http_parser-3.1.44.0.0
intl-0.16.10.17.0
js-0.6.20.6.3
logging-0.11.41.0.0
matcher-0.12.90.12.10
meta-1.2.41.3.0
node_interop-1.2.11.2.1
node_io-1.2.01.2.0
package_config-1.9.32.0.0
path-1.7.01.8.0
pedantic-1.9.21.10.0
pub_semver-1.4.42.0.0
quiver-2.1.53.0.0
source_span-1.7.01.8.1
stack_trace-1.9.61.10.0
string_scanner-1.0.51.1.0
term_glyph-1.1.01.2.0
typed_data-1.2.01.3.0
watcher-0.9.7+151.0.0
yaml-2.2.13.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^4.2.0` on built_collection does not support the stable version `5.0.0`, that was published 20 days ago.

When built_collection is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions built_collection to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.1+1, Dart 2.10.5.

9
likes
75
pub points
92%
popularity

Publisher

mings.in

retrofit generator is an dio client generator using source_gen and inspired by Chopper and Retrofit.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

analyzer, build, built_collection, code_builder, dart_style, dio, retrofit, source_gen, tuple

More

Packages that depend on retrofit_generator