rest_data 1.1.0 copy "rest_data: ^1.1.0" to clipboard
rest_data: ^1.1.0 copied to clipboard

Easily interact with REST APIs without dealing with HTTP and JSON

8
likes
90/ 140
pub points
46%
popularity

We analyzed this package 4 days ago, and awarded it 90 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

5 out of 191 API elements (2.6 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: rest_data, rest_data.Adapter, rest_data.Adapter.Adapter, rest_data.Adapter.cache, rest_data.Adapter.cacheMany.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:rest_data/rest_data.dart that imports:
  • package:rest_data/src/adapters/json_api.dart that imports:
  • package:rest_data/src/adapters/mixins/http.dart that imports:
  • dart:io
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 5 issues. Showing the first 2:

WARNING: Unnecessary type check; the result is always 'true'.

lib/src/adapters/json_api.dart:209:11

    ╷
209 │       if (docCache is Map) {
    │           ^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/adapters/json_api.dart

INFO: Using a colon as the separator before a default value is deprecated and will not be supported in language version 3.0 and later.

lib/src/adapters/json_api.dart:13:16

   ╷
13 │     bool useSSL: true,
   │                ^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/adapters/json_api.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
equatable ^2.0.3 2.0.5 2.0.5
http ^0.13.3 0.13.6 1.2.1
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
collection - 1.18.0 1.18.0
http_parser - 4.0.2 4.0.2
meta - 1.12.0 1.12.0
path - 1.9.0 1.9.0
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.13.3` on http does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.1, Dart 3.4.0-131.0.dev.

Check the analysis log for details.

8
likes
90
pub points
46%
popularity

Publisher

verified publisheralgonauti.com

Easily interact with REST APIs without dealing with HTTP and JSON

Homepage

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

equatable, http

More

Packages that depend on rest_data