rest_api_builder_generator 1.1.1

Rest API Builder Generator #

Rest api builder generator for rest API builder

How to publish? #

If you just check validation, run following command:

flutter packages pub publish --dry-run

To publish the library, run following command:

flutter packages pub publish

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  rest_api_builder_generator: ^1.1.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:rest_api_builder_generator/rest_api_builder_generator.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
18
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
20
Overall:
Weighted score of the above. [more]
43
Learn more about scoring.

We analyzed this package on Jul 20, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19

Platforms

Detected platforms: other

Primary library: package:rest_api_builder_generator/rest_api_builder_generator.dart with components: io, isolate, build, mirrors.

Health issues and suggestions

Document public APIs. (-1 points)

2 out of 2 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Format lib/rest_api_builder_generator.dart.

Run dartfmt to format lib/rest_api_builder_generator.dart.

Format lib/src/api_builders.dart.

Run dartfmt to format lib/src/api_builders.dart.

Maintenance issues and suggestions

Support latest dependencies. (-30 points)

The version constraint in pubspec.yaml does not support the latest published versions for 3 dependencies (analyzer, build, source_gen).

Provide a file named CHANGELOG.md. (-20 points)

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and rest_api_builder_generator.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
analyzer ^0.32.0 0.32.6 0.37.0
build >=0.12.0 <2.0.0 1.1.0 1.1.5
rest_api_builder ^1.0.1 1.1.1
source_gen ^0.9.0 0.9.1+3 0.9.4+3
Transitive dependencies
args 1.5.2
async 2.3.0
charcode 1.1.2
collection 1.14.11
convert 2.1.1
crypto 2.0.6
csslib 0.16.1
dart_style 1.1.3 1.2.9
front_end 0.1.4+2 0.1.20
glob 1.1.7
html 0.14.0+2
kernel 0.3.4+2 0.3.20
logging 0.11.3+2
meta 1.1.7
package_config 1.0.5
path 1.6.2
pedantic 1.8.0+1
plugin 0.2.0+3
source_span 1.5.5
string_scanner 1.0.4
term_glyph 1.1.0
typed_data 1.1.6
watcher 0.9.7+12
yaml 2.1.16
Dev dependencies
build_runner >=0.9.0 <0.11.0
build_test ^0.10.0
test ^1.5.3

Admin