rest_api_builder_generator 1.2.9

Dart native

Api builder generator for rest call

1
likes
45 / 110
pub points
1 %
popularity

We analyzed this package on Sep 19, 2020, and awarded it 45 pub points (of a possible 110):

Follow Dart file conventions
5 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

No `CHANGELOG.md` found.

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 2 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:rest_api_builder_generator/rest_api_builder_generator.dart that imports:
  • package:rest_api_builder_generator/src/api_builders.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/utils.dart that imports:
  • package:build/build.dart that imports:
  • package:build/src/generate/run_post_process_builder.dart that imports:
  • package:build/src/builder/post_process_builder.dart that imports:
  • package:build/src/builder/builder.dart that imports:
  • package:build/src/builder/build_step.dart that imports:
  • package:build/src/asset/reader.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:glob/src/io.dart that imports:
  • package:glob/src/io_export.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/rest_api_builder_generator.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/src/api_builders.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer^0.39.00.39.170.40.2
build>=0.12.8 <2.0.01.4.01.4.0
recase^2.0.12.0.13.0.0
rest_api_builder^1.1.61.1.61.1.6
source_gen^0.9.00.9.60.9.6
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-7.0.09.0.0
args-1.6.01.6.0
async-2.4.22.4.2
charcode-1.1.31.1.3
cli_util-0.2.00.2.0
collection-1.14.131.14.13
convert-2.1.12.1.1
crypto-2.1.52.1.5
csslib-0.16.20.16.2
dart_style-1.3.61.3.7
glob-1.2.01.2.0
html-0.14.0+30.14.0+3
js-0.6.20.6.2
logging-0.11.40.11.4
meta-1.2.31.2.3
node_interop-1.1.11.1.1
node_io-1.1.11.1.1
package_config-1.9.31.9.3
path-1.7.01.7.0
pedantic-1.9.21.9.2
pub_semver-1.4.41.4.4
source_span-1.7.01.7.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0
watcher-0.9.7+150.9.7+15
yaml-2.2.12.2.1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.39.0` on analyzer does not support the latest published version `0.40.2`

pubspec.yaml:16:13

   ╷
16 │   analyzer: ^0.39.0
   │             ^^^^^^^
   ╵
The constraint `^2.0.1` on recase does not support the latest published version `3.0.0`

pubspec.yaml:17:11

   ╷
17 │   recase: ^2.0.1
   │           ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs