requests 3.3.0
requests: ^3.3.0 copied to clipboard

a flutter library that helps with http requests and stored cookies

43
likes
60/ 130
pub points
89%
popularity

We analyzed this package on Oct 20, 2021, and awarded it 60 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 48 API elements (2.1 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:requests/requests.dart that imports:
  • package:requests/src/requests.dart that imports:
  • package:requests/src/common.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_windows/shared_preferences_windows.dart that declares support for platforms: Windows.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/src/common.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/src/requests.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

  • Could not run flutter pub outdated: dart pub get failed:
OUT:
Resolving dependencies...
ERR:
The current Dart SDK version is 2.14.3.

Because test >=1.16.0-nullsafety <1.16.0-nullsafety.8 requires SDK version >=2.10.0-0 <2.12.0 and test >=1.16.0-nullsafety.8 <1.16.0-nullsafety.18 depends on typed_data >=1.3.0-nullsafety <1.3.0,[...]
And because test >=1.16.0-nullsafety.18 <1.16.0-nullsafety.19 depends on test_api 0.2.19-nullsafety.7 and test >=0.12.0-beta.3 <1.3.0 requires SDK version >=1.8.0 <2.0.0-∞, test >=0.12.0-beta.3 <[...]
And because test >=1.3.0 <1.12.0 depends on boolean_selector ^1.0.0 and test >=1.12.0 <1.13.0 depends on test_api 0.2.14, test >=0.12.0-beta.3 <1.13.0-∞ or >=1.16.0-nullsafety <1.16.0-nullsafety.[...]
And because test >=1.13.0 <1.14.5 depends on test_api 0.2.15 and test >=1.14.5 <1.15.0 depends on test_api 0.2.16, test >=0.12.0-beta.3 <1.15.0-∞ or >=1.16.0-nullsafety <1.16.0-nullsafety.19 requ[...]
And because test >=1.15.0 <1.15.3 depends on test_api 0.2.17 and test >=1.15.3 <1.15.5 depends on test_api 0.2.18, test >=0.12.0-beta.3 <1.15.5-∞ or >=1.16.0-nullsafety <1.16.0-nullsafety.19 requ[...]
And because test >=1.15.5 <1.16.0-nullsafety depends on test_api 0.2.18+1 and test >=1.16.0-nullsafety.19 <1.16.6 depends on test_api 0.2.19, test >=0.12.0-beta.3 <1.16.6 requires test_api 0.2.14[...]
And because every version of flutter_test from sdk depends on both boolean_selector 2.1.0 and test_api 0.4.2, if test >=0.12.0-beta.3 <1.16.6 and flutter_test any from sdk then typed_data >=1.3.0[...]
And because every version of flutter_test from sdk depends on typed_data 1.3.0 and test >=1.16.6 depends on webkit_inspection_protocol ^1.0.0, if flutter_test any from sdk and test >=0.12.0-beta.[...]
[2 more lines]

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.0.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.

43
likes
60
pub points
89%
popularity

a flutter library that helps with http requests and stored cookies

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

crypto, flutter, hex, http, logging, shared_preferences

More

Packages that depend on requests