reloader 0.1.2
reloader: ^0.1.2 copied to clipboard

A library to reload dart VM if code was changed. Tool reloads your code when source was changed.

1
likes
75 / 130
pub points
0 %
popularity

We analyzed this package on May 8, 2021, and awarded it 75 pub points (of a possible 130):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

No `README.md` found.

The README.md file should inform others about your project, what it does, and how they can use it. See: the example generated by stagehand.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 4 API elements (50.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:reloader/runner.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

INFO: Use isEmpty instead of length

bin/reloader.dart:17:7

   ╷
17 │   if (arguments.length < 1) {
   │       ^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer bin/reloader.dart

INFO: `Future` results in `async` function bodies must be `await`ed or marked `unawaited` using `package:pedantic`.

bin/reloader.dart:49:5

   ╷
49 │     proc.exitCode.then((code) => exit(0));
   │     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer bin/reloader.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
path^1.6.21.8.01.8.0
vm_service_lib^0.3.50.3.10+23.22.2+1
watcher^0.9.70.9.7+151.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.6.12.6.1
collection-1.15.01.15.0
meta-1.3.01.3.0
pedantic-1.11.01.11.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.3.5` on vm_service_lib does not support the stable version `3.14.1`.

Try running dart pub upgrade --major-versions vm_service_lib to update the constraint.

The constraint `^0.9.7` on watcher does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions watcher to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.0.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Dart 2.12.4.

1
likes
75
pub points
0%
popularity

A library to reload dart VM if code was changed. Tool reloads your code when source was changed.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

0xff00ff@gmail.com

License

BSD (LICENSE)

Dependencies

path, vm_service_lib, watcher

More

Packages that depend on reloader