Tool for reloading project when sources are changed
$ pub global activate reloader $ reloader /dir/to/monitor /file/to/execute.dart or $ reloader /file/to/execute.dart // if you want to monitor current directory
All notable changes to this project will be documented in this file.
// pub global activate reloader // reloader /dir/to/monitor /file/to/execute.dart // or if you want to monitor current directory // reloader /file/to/execute.dart
You can install the package from the command line:
$ pub global activate reloader
The package has the following executables:
Add this to your package's pubspec.yaml file:
dependencies: reloader: ^0.1.2
You can install packages from the command line:
$ pub get
$ flutter pub get
Alternatively, your editor might support
pub get or
flutter pub get.
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
import 'package:reloader/runner.dart'; import 'package:reloader/watcher.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
We analyzed this package on Jul 22, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
Detected platforms: Flutter, other
Platform components identified in package:
bin/reloader.dart. (-1 points)
bin/reloader.dart reported 2 hints:
line 17 col 7: Use isEmpty instead of length
line 49 col 5:
Future results in
async function bodies must be
awaited or marked
lib/runner.dart. (-0.50 points)
lib/runner.dart reported 1 hint:
line 5 col 1: The class 'Future' was not exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.
lib/watcher.dart. (-0.50 points)
lib/watcher.dart reported 1 hint:
line 5 col 1: The class 'Stream' was not exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.
Support latest dependencies. (-10 points)
The version constraint in
pubspec.yaml does not support the latest published versions for 1 dependency (