reloader 0.1.2

Reloader

Tool for reloading project when sources are changed

$ pub global activate reloader

$ reloader /dir/to/monitor /file/to/execute.dart
or 
$ reloader /file/to/execute.dart // if you want to monitor current directory
  • reload project on any changes in directory (add/edit/remove file)
  • simple to use

Roadmap:

  • add directory exceptions
  • add event exceptions (do not reload on file addition)

Changelog #

All notable changes to this project will be documented in this file.

[0.0.1] - 2019-01-08

Added #

  • Basic functionality

example/example.dart

// pub global activate reloader

// reloader /dir/to/monitor /file/to/execute.dart
// or if you want to monitor current directory
// reloader /file/to/execute.dart

Use this package as an executable

1. Install it

You can install the package from the command line:


$ pub global activate reloader

2. Use it

The package has the following executables:


$ reloader

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  reloader: ^0.1.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:reloader/runner.dart';
import 'package:reloader/watcher.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
98
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
47
Learn more about scoring.

We analyzed this package on Jul 22, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19

Platforms

Detected platforms: Flutter, other

Platform components identified in package: io.

Health suggestions

Fix bin/reloader.dart. (-1 points)

Analysis of bin/reloader.dart reported 2 hints:

line 17 col 7: Use isEmpty instead of length

line 49 col 5: Future results in async function bodies must be awaited or marked unawaited using package:pedantic.

Fix lib/runner.dart. (-0.50 points)

Analysis of lib/runner.dart reported 1 hint:

line 5 col 1: The class 'Future' was not exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

Fix lib/watcher.dart. (-0.50 points)

Analysis of lib/watcher.dart reported 1 hint:

line 5 col 1: The class 'Stream' was not exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (vm_service_lib).

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
path ^1.6.2 1.6.2
vm_service_lib ^0.3.5 0.3.10+2 3.22.2
watcher ^0.9.7 0.9.7+12
Transitive dependencies
async 2.3.0
collection 1.14.11
pedantic 1.8.0+1

Admin