redux_toolkit 0.1.4 icon indicating copy to clipboard operation
redux_toolkit: ^0.1.4 copied to clipboard

Dart port of the official, opinionated, batteries-included toolset for efficient Redux development

4
likes
100/ 130
pub points
28%
popularity

We analyzed this package 2 days ago, and awarded it 100 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 26 out of 45 API elements (57.8 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
meta>=1.1.1 <2.0.01.8.01.8.0
redux>=4.0.0 <5.0.04.0.0+35.0.0
redux_dev_tools>=0.5.2 <1.0.00.5.20.7.0
redux_remote_devtools>=2.0.0 <3.0.02.0.03.0.0
redux_thunk>=0.3.0 <1.0.00.3.00.4.0
reselect>=0.4.0 <1.0.00.5.00.5.0
Transitive dependencies
PackageConstraintCompatibleLatest
memoize-3.0.03.0.0
socketcluster_client-0.2.00.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=4.0.0 <5.0.0` on redux does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions redux to update the constraint.

The constraint `>=2.0.0 <3.0.0` on redux_remote_devtools does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions redux_remote_devtools to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.0.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.12, Dart 2.17.3.

4
likes
100
pub points
28%
popularity

Publisher

unverified uploader

Dart port of the official, opinionated, batteries-included toolset for efficient Redux development

Repository (GitHub)
View/report issues

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

meta, redux, redux_dev_tools, redux_remote_devtools, redux_thunk, reselect

More

Packages that depend on redux_toolkit