reducer_extension_gen 0.0.2
reducer_extension_gen: ^0.0.2 copied to clipboard

Dart native

Automatically generating `reducer` extensions code for classes with `@actionReducer` annotation.

0
likes
90 / 110
pub points
0 %
popularity

We analyzed this package on Jan 26, 2021, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 2 API elements (100.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:reducer_extension_gen/builder.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/utils.dart that imports:
  • package:build/build.dart that imports:
  • package:build/src/generate/run_post_process_builder.dart that imports:
  • package:build/src/builder/post_process_builder.dart that imports:
  • package:build/src/builder/builder.dart that imports:
  • package:build/src/builder/build_step.dart that imports:
  • package:build/src/asset/reader.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:glob/src/io.dart that imports:
  • package:glob/src/io_export.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: 'name' is deprecated and shouldn't be used. Check element, or use getDisplayString().

lib/src/reducer_generator.dart:125:34

    ╷
125 │         this.type = element.type.name;
    │                                  ^^^^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/reducer_generator.dart

lib/src/reducer_generator.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer>=0.39.0 <1.0.00.41.20.41.2
build>=1.0.0 <2.0.01.6.11.6.1
logging>=0.0.0 <1.0.00.11.40.11.4
reducer_extension>=0.0.2 <2.0.00.0.20.0.2
source_gen>=0.9.0 <1.0.00.9.10+10.9.10+1
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-14.0.014.0.0
args-1.6.01.6.0
async-2.4.22.4.2
charcode-1.1.31.1.3
cli_util-0.2.00.2.0
collection-1.14.131.14.13
convert-2.1.12.1.1
crypto-2.1.52.1.5
dart_style-1.3.111.3.11
file-5.2.15.2.1
glob-1.2.01.2.0
intl-0.16.10.16.1
js-0.6.20.6.2
meta-1.2.41.2.4
node_interop-1.2.11.2.1
node_io-1.2.01.2.0
package_config-1.9.31.9.3
path-1.7.01.7.0
pedantic-1.9.21.9.2
pub_semver-1.4.41.4.4
source_span-1.7.01.7.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0
watcher-0.9.7+150.9.7+15
yaml-2.2.12.2.1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
90
pub points
0%
popularity

Automatically generating `reducer` extensions code for classes with `@actionReducer` annotation.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

julien.zarka@mobile-devices.fr

License

MIT (LICENSE)

Dependencies

analyzer, build, logging, reducer_extension, source_gen

More

Packages that depend on reducer_extension_gen