reducer_extension 0.0.2

  • Readme
  • Changelog
  • Example
  • Installing
  • 59

Provides source_gen Generator for generating reducer extension. For more info on this package check out his blog article.

reducer_extension #

reducer_extension_gen #

0.0.2 Fix name clash with Reducer Class from redux #

  • change annotation from @reducer to @actionReducer since it generates both action and reducer.

0.0.1 Initial release #

  • Lets you annotate an object using @reducer to generate a reducer extension.

example/example.dart

import 'package:meta/meta.dart' show immutable;
import 'package:reducer_extension/reducer_extension.dart';

/// Make sure to import redux
import 'package:redux/redux.dart';

/// Make sure that `part` is specified, even before launching the builder
part 'example.g.dart';

@immutable
@actionReducer
class SimpleObject {
  final String id;
  final int value;

  const SimpleObject({this.id, this.value});

  // Make sure you implement the copyWith pattern
  SimpleObject copyWith({String id, int value}) => SimpleObject(id: id ?? this.id, value: value ?? this.value);
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  reducer_extension: ^0.0.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:reducer_extension/reducer_extension.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
22
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
59
Learn more about scoring.

We analyzed this package on Jul 14, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.15

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
Dev dependencies
build_runner >=1.0.0 <2.0.0
reducer_extension_gen >=0.0.2 <1.0.0
test <2.0.0