reactive_multi_image_picker 0.9.0 copy "reactive_multi_image_picker: ^0.9.0" to clipboard
reactive_multi_image_picker: ^0.9.0 copied to clipboard

discontinued
PlatformAndroidiOS

Wrapper around multi_image_picker to use with reactive_forms

2
likes
100/ 140
pub points
73%
popularity

We analyzed this package 6 hours ago, and awarded it 100 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: reactive_multi_image_picker,
    • contains a version property, and,
    • does not contain a publish_to property.

Repository has no matching pubspec.yaml with name: reactive_multi_image_picker.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

164 out of 246 API elements (66.7 %) have documentation comments.

Some symbols that are missing documentation: multi_image, multi_image.MultiImage, multi_image.MultiImage.MultiImage, multi_image.MultiImage.assets, multi_image.MultiImage.copyWith.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:reactive_multi_image_picker/reactive_multi_image_picker.dart that imports:
  • package:reactive_multi_image_picker/multi_image.dart that imports:
  • package:multi_image_picker/multi_image_picker.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:reactive_multi_image_picker/reactive_multi_image_picker.dart that imports:
  • package:reactive_multi_image_picker/multi_image.dart that imports:
  • package:multi_image_picker/multi_image_picker.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:reactive_multi_image_picker/reactive_multi_image_picker.dart that imports:
  • package:reactive_multi_image_picker/multi_image.dart that imports:
  • package:multi_image_picker/multi_image_picker.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:reactive_multi_image_picker/reactive_multi_image_picker.dart that imports:
  • package:reactive_multi_image_picker/multi_image.dart that imports:
  • package:multi_image_picker/multi_image_picker.dart that declares support for platforms: Android, iOS.
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

WARNING: The parameter type of '==' operators should be non-nullable.

lib/multi_image.freezed.dart:132:17

    ╷
132 │   bool operator ==(dynamic other) {
    │                 ^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/multi_image.freezed.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
freezed_annotation ^2.2.0 2.4.1 2.4.1
multi_image_picker ^4.8.1 4.8.01 4.8.01
reactive_forms ^14.2.0 14.3.0 17.0.1
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
intl - 0.18.1 0.19.0
json_annotation - 4.9.0 4.9.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^14.2.0` on reactive_forms does not support the stable version `15.0.0`.

Try running dart pub upgrade --major-versions reactive_forms to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.1, Dart 3.4.1.

Check the analysis log for details.

2
likes
100
pub points
73%
popularity

Publisher

unverified uploader

Wrapper around multi_image_picker to use with reactive_forms

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, freezed_annotation, multi_image_picker, reactive_forms

More

Packages that depend on reactive_multi_image_picker