reactive_file_picker 0.3.0
reactive_file_picker: ^0.3.0 copied to clipboard

Wrapper around file_picker to use with reactive_forms.

1
likes
120/ 130
pub points
53%
popularity

We analyzed this package on Oct 20, 2021, and awarded it 120 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 3 out of 14 API elements (21.4 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

These issues are present but do not affect the score, because they may not originate in your package:

Package not compatible with runtime flutter-web on Web

Because:

  • package:reactive_file_picker/reactive_file_picker.dart that imports:
  • package:reactive_file_picker/multi_file.dart that imports:
  • package:file_picker/file_picker.dart that imports:
  • package:file_picker/src/file_picker.dart that imports:
  • package:file_picker/src/file_picker_macos.dart that imports:
  • package:file_picker/src/utils.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
file_picker^4.1.34.1.54.1.5
flutterflutter0.0.00.0.0
freezed_annotation^0.14.30.14.30.15.0
reactive_forms^10.6.210.6.210.6.2
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
clock-1.1.01.1.0
collection-1.15.01.15.0
ffi-1.1.21.1.2
flutter_plugin_android_lifecycle-2.0.42.0.4
flutter_web_plugins-0.0.00.0.0
intl-0.17.00.17.0
js-0.6.30.6.3
json_annotation-4.3.04.3.0
meta-1.7.01.7.0
path-1.8.01.8.0
plugin_platform_interface-2.0.22.0.2
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.14.3` on freezed_annotation does not support the stable version `0.15.0`, that was published 12 days ago.

When freezed_annotation is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions freezed_annotation to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.