react 6.0.1
react: ^6.0.1 copied to clipboard

Bindings of the ReactJS library for building interactive interfaces.

27
likes
90 / 110
pub points
81 %
popularity

We analyzed this package on Apr 13, 2021, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/README.md

10/10 points: 20% or more of the public API has dartdoc comments

  • 591 out of 812 API elements (72.8 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime native

Because:

  • package:react/react.dart that imports:
  • package:react/src/react_client/synthetic_data_transfer.dart that imports:
  • package:react/src/react_client/synthetic_event_wrappers.dart that imports:
  • package:js/js.dart that imports:
  • dart:js
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 104 issues. Showing the first 2:

INFO: Unnecessary new keyword.

lib/react.dart:197:20

    ╷
197 │     this.context = new Map.from(context ?? const {});
    │                    ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/react.dart

INFO: Unnecessary new keyword.

lib/react.dart:202:24

    ╷
202 │     this.nextContext = new Map.from(this.context ?? const {});
    │                        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/react.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
js^0.6.00.6.30.6.3
meta^1.1.61.3.01.3.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Dart 2.12.2.

27
likes
90
pub points
81%
popularity

Publisher

workiva.com

Bindings of the ReactJS library for building interactive interfaces.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

js, meta

More

Packages that depend on react