raylib 0.3.0 icon indicating copy to clipboard operation
raylib: ^0.3.0 copied to clipboard

raylib is a simple and easy-to-use library to enjoy videogames programming.

Raylib #

plugin version coverage report pipeline status dependencies Examples

Dart bindings for raylib, a simple and easy-to-use library to enjoy videogames programming.

Note: This package was written for raylib version 4.x and higher, older versions are not supported.

Currently this library does not support the following platforms:

  • iOS, raylib is built on top of OpenGL and that isn't supported on iOS.
  • macOS, raylib creates windows natively but on macOS that is only possible if you do it from the main thread but sadly the Dart VM is not the main thread. For more information check this issue and this one.

Not every binding has been fully tested. If you find a bug I would appreciate it if you created an issue on the repo.

Usage #

Add raylib as a dependency to your pubspec.yaml file (what?).

Importing raylib:

import 'package:raylib/raylib.dart';

You need to tell the package where it can find your raylib library:

initLibrary(
  linux: '../include/libraylib.so',
  windows: '../somewhere/else',
);

See the example directory for examples.

Development #

Linux #

You need to have both make and git installed:

sudo apt install build-essential git

After that you can check out the submodules:

git submodule update --init --recursive

With the submodules downloaded you can start compiling raylib:

cd vendor/raylib/src
make PLATFORM=PLATFORM_DESKTOP RAYLIB_LIBTYPE=SHARED

Then copy the compiled library to the example folder:

cp ../libraylib.so.4.0.0 ../../../example/include/libraylib.so
11
likes
130
pub points
33%
popularity

Publisher

shield icon for verified publisherswolfenra.in

raylib is a simple and easy-to-use library to enjoy videogames programming.

Repository (GitLab)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

collection, ffi

More

Packages that depend on raylib