rate_my_app 0.2.0+4

Rate my app ! #

This plugin allows to kindly ask users to rate your app if custom conditions are met (eg. install time, number of launches, etc...).

Rate my app is really inspired by Android-Rate.

How to use #

Installation #

To target an iOS version before 10.3, add this in your Info.plist :

<key>LSApplicationQueriesSchemes</key>
<array>
    <string>itms</string>
</array>

By the way, it's important to note that your bundle identifier (in your Info.plist) must match the App ID on iTunes Connect and the package identifier (in your build.gradle) must match your App ID on Google Play.

If for any reason it doesn't match please go to the Using custom identifiers section.

How it works #

Rate my app takes two parameters :

  1. minDays Minimum elapsed days since the first app launch.
  2. minLaunches Minimum launches.

If everything above is verified, the method shouldOpenDialog will return true (false otherwise). Then you should call showRateDialog which is going to show a native rating dialog on iOS >= 10.3 and a custom rating prompt dialog on Android (and on older iOS versions).

Using custom identifiers #

It's possible to use custom identifiers ! Just pass the following parameters during the plugin initialization :

  1. googlePlayIdentifier Your Google Play identifier (usually a package name).
  2. appStoreIdentifier Your App Store identifier (usually numbers). It's required if you're targeting an iOS version before iOS 10.3.

Screenshots #

On Android #

Android screenshot

On iOS #

iOS < 10.3

No screenshot for the moment. If you have one, please don't hesitate to submit it !

iOS >= 10.3 #

iOS 10.3 screenshot

Example #

RateMyApp rateMyApp = RateMyApp(
  minDays: 7,
  minLaunches: 10,
  remindDays: 7,
  remindLaunches: 10,
);

_rateMyApp.init().then((_) {
  if (_rateMyApp.shouldOpenDialog) {
    _rateMyApp.showRateDialog(
      context,
      title: 'Rate this app',
      message: 'If you like this app, please take a little bit of your time to review it !\nIt really helps us and it shouldn\'t take you more than one minute.',
      rateButton: 'RATE',
      noButton: 'NO THANKS',
      laterButton: 'MAYBE LATER',
    );
  }
});

Dependencies #

This library depends on some other libraries :

0.2.0+4 #

  • preferencesPrefix was not used. As it changes preference keys, this release resets Rate my app user preferences.
  • baseLaunchDate not affected by the Maybe Later button.

0.2.0+3 #

  • Fixed remindLaunches constantly triggering.

0.2.0+2 #

  • Updated README and examples.

0.2.0+1 #

  • Updated minimum SDK version.

0.2.0 #

  • Added the ability to use custom identifiers.
  • Removed a dependency.
  • Fixed a bug where the dialog was not closing after the user successfully clicked on "Rate".

0.1.0 #

  • First published release.

example/README.md

Examples #

If you want a "real project" example, you can check this one on Github.

If you want a little snippet, go to the projet page.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  rate_my_app: ^0.2.0+4

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:rate_my_app/rate_my_app.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
86
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
93
Learn more about scoring.

We analyzed this package on Jul 17, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19
  • Flutter: 1.7.8+hotfix.3

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Format lib/rate_my_app.dart.

Run flutter format to format lib/rate_my_app.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
shared_preferences ^0.5.3 0.5.3+4
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8

Admin