rapido 0.2.4

Flutter Android iOS

Rapid Application Development for Flutter. Automatically persisting user data, and creates default CRUD UI.

8
likes
80 / 110
pub points
59 %
popularity

We analyzed this package on Oct 27, 2020, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 182 out of 246 API elements (74.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:rapido/rapido.dart that imports:
  • package:rapido/src/persistence.dart that imports:
  • package:flutter_secure_storage/flutter_secure_storage.dart that declares support for platforms: Android, iOS

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:rapido/rapido.dart that imports:
  • package:rapido/src/persistence.dart that imports:
  • package:flutter_secure_storage/flutter_secure_storage.dart that declares support for platforms: Android, iOS
Package does not support Flutter platform Linux

Because:

  • package:rapido/rapido.dart that imports:
  • package:rapido/src/persistence.dart that imports:
  • package:flutter_secure_storage/flutter_secure_storage.dart that declares support for platforms: Android, iOS
Package does not support Flutter platform macOS

Because:

  • package:rapido/rapido.dart that imports:
  • package:rapido/src/persistence.dart that imports:
  • package:flutter_secure_storage/flutter_secure_storage.dart that declares support for platforms: Android, iOS

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support Flutter platform Android

Because:

  • package:rapido/rapido.dart that imports:
  • package:rapido/src/persistence.dart that imports:
  • package:path_provider/path_provider.dart that imports:
  • package:path_provider_windows/path_provider_windows.dart that declares support for platforms: Windows
Package does not support Flutter platform iOS

Because:

  • package:rapido/rapido.dart that imports:
  • package:rapido/src/persistence.dart that imports:
  • package:path_provider/path_provider.dart that imports:
  • package:path_provider_windows/path_provider_windows.dart that declares support for platforms: Windows
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 11 issues. Showing the first 2:

INFO: 'headline' is deprecated and shouldn't be used. This is the term used in the 2014 version of material design. The modern term is headline5. This feature was deprecated after v1.13.8..

lib/src/document_page.dart:49:50

   ╷
49 │               style: Theme.of(context).textTheme.headline,
   │                                                  ^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/document_page.dart

INFO: 'pickImage' is deprecated and shouldn't be used. Use imagePicker.getImage() method instead..

lib/src/image_form_field.dart:168:35

    ╷
168 │     File file = await ImagePicker.pickImage(source: source);
    │                                   ^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/image_form_field.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
datetime_picker_formfield^1.0.01.0.01.0.0
flutterflutter0.0.00.0.0
flutter_secure_storage^3.3.1+13.3.53.3.5
google_maps_flutter^0.5.21+150.5.331.0.3
image_picker^0.6.2+30.6.7+120.6.7+12
intl>=0.15.0 <1.0.00.16.10.16.1
location^2.3.52.5.43.0.2
numberpicker^1.1.01.2.11.2.1
parse_server_sdk^1.0.241.0.282.0.1
passwordfield^0.0.50.0.820.0.82
path^1.6.41.7.01.8.0-nullsafety.2
path_provider^1.5.11.6.221.6.22
validators^2.0.02.0.12.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
asn1lib-0.6.50.8.1
async-2.4.22.5.0-nullsafety.2
basic_utils-2.6.32.6.3
characters-1.1.0-nullsafety.31.1.0-nullsafety.4
charcode-1.1.31.2.0-nullsafety.2
collection-1.15.0-nullsafety.31.15.0-nullsafety.4
convert-2.1.12.1.1
crypto-2.1.52.1.5
dio-3.0.103.0.10
ffi-0.1.30.1.3
file-5.2.15.2.1
flutter_plugin_android_lifecycle-1.0.111.0.11
google_maps_flutter_platform_interface-1.0.41.0.4
http-0.12.20.12.2
http_parser-3.1.43.1.4
idb_shim-1.12.01.12.0
image_picker_platform_interface-1.1.11.1.1
infinite_listview-1.0.1+11.0.1+1
js-0.6.20.6.3-nullsafety.2
json_annotation-3.0.13.1.0
logging-0.11.40.11.4
meta-1.3.0-nullsafety.31.3.0-nullsafety.5
mime_type-0.3.20.3.2
path_provider_linux-0.0.1+20.0.1+2
path_provider_macos-0.0.4+40.0.4+4
path_provider_platform_interface-1.0.31.0.3
path_provider_windows-0.0.4+10.0.4+1
pedantic-1.9.21.10.0-nullsafety.2
platform-2.2.12.2.1
plugin_platform_interface-1.0.31.0.3
pointycastle-1.0.22.0.0
process-3.0.133.0.13
random_string-2.1.02.1.0
sembast-2.4.7+72.4.7+7
sembast_web-1.2.01.2.0
sky_engine-0.0.990.0.99
source_span-1.7.01.8.0-nullsafety.3
stream_channel-2.0.02.1.0-nullsafety.2
stream_transform-1.2.01.2.0
string_scanner-1.0.51.1.0-nullsafety.2
synchronized-2.2.0+22.2.0+2
term_glyph-1.1.01.2.0-nullsafety.2
typed_data-1.3.0-nullsafety.31.3.0-nullsafety.4
uuid-2.2.22.2.2
vector_math-2.1.0-nullsafety.32.1.0-nullsafety.4
vin_decoder-0.1.20.1.2
web_socket_channel-1.1.01.1.0
win32-1.7.31.7.3
xdg_directories-0.1.20.1.2
xxtea-2.0.32.0.3

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^0.5.21+15` on google_maps_flutter does not support the latest published version `1.0.3`

pubspec.yaml:16:24

   ╷
16 │   google_maps_flutter: ^0.5.21+15
   │                        ^^^^^^^^^^
   ╵
The constraint `^2.3.5` on location does not support the latest published version `3.0.2`

pubspec.yaml:15:13

   ╷
15 │   location: ^2.3.5
   │             ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs