range_calendar 0.0.4-dev.1 copy "range_calendar: ^0.0.4-dev.1" to clipboard
range_calendar: ^0.0.4-dev.1 copied to clipboard

The range_calendar package has a calendar with daily, weekly and monthly selection option. Just insert a Map<DateTime, List<Widgets>> to perform displaying and filtering events.

8
likes
110/ 140
pub points
2%
popularity

We analyzed this package 2 days ago, and awarded it 110 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: GPL-3.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

19 out of 28 API elements (67.9 %) have documentation comments.

Some symbols that are missing documentation: range_calendar, range_calendar.DayCalendar.day, range_calendar.DayCalendar.isDaySelected, range_calendar.DayCalendar.isEndRange, range_calendar.DayCalendar.isInitRange.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

WARNING: The value of the local variable 'day' isn't used.

lib/range_calendar.dart:434:9

    ╷
434 │     int day = date.day;
    │         ^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/range_calendar.dart

INFO: Use 'isNotEmpty' instead of 'length' to test whether the collection is empty.

lib/range_calendar.dart:271:23

    ╷
271 │                       listDayCalendar.length > 0
    │                       ^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/range_calendar.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
material_design_icons_flutter ^5.0.5955-rc.1 5.0.6996 7.0.7296
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^5.0.5955-rc.1` on material_design_icons_flutter does not support the stable version `6.0.7096`.

Try running dart pub upgrade --major-versions material_design_icons_flutter to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.0, Flutter 3.19.0, Dart 3.3.0.

Check the analysis log for details.

8
likes
110
pub points
2%
popularity

Publisher

unverified uploader

The range_calendar package has a calendar with daily, weekly and monthly selection option. Just insert a Map<DateTime, List<Widgets>> to perform displaying and filtering events.

Repository (GitHub)
View/report issues

Documentation

API reference

License

GPL-3.0 (LICENSE)

Dependencies

flutter, material_design_icons_flutter

More

Packages that depend on range_calendar