rabbit_converter 1.0.0

  • Readme
  • Changelog
  • Example
  • Installing
  • 84

flutter_rabbit #

Rabbit Converter package for Flutter. This is a wrapper for Rabbit Converter.

Features #

  • Converts from ZawGyi to Myanmar Unicode.
  • Converts from Myanmar Unicode to ZawGyi.

Usage #

You must add the library as a dependency to your project.

dependencies:
 rabbit_converter: ^0.0.1

You should then run flutter packages get

After that, import the package in your dart file.

import 'package:rabbit_converter/rabbit_converter.dart';

Simply call the function to convert the string.

  String text = 'ယေဓမ္မာ ဟေတုပ္ပဘဝါ တေသံ ဟေတုံ တထာဂတော အာဟ တေသဉ္စ ယောနိရောဓေါ ဧဝံ ဝါဒီ မဟာသမဏော။';
  String zawgyiText = Rabbit.uni2zg(text);
  String unicodeText = Rabbit.zg2uni(zawgyiText);

##

Example Project #

There is a detailed example project in the example folder. You can directly run and play on it. There are code snippets from example project below.

##

Contributions #

  • If you found a bug, open an issue.
  • If you have a feature request, open an issue.
  • If you want to contribute, submit a pull request.

Version compatibility #

See CHANGELOG for all breaking (and non-breaking) changes.


Packaged by frozencity.
Rabbit Converter written in Dart by frencojobs.
Rabbit Converter written originally by saturngod.

[0.0.1] - Feb 2020. #

  • Initial Release. Added a Rabbit Converter Library.

[1.0.0] - Feb 2020. #

  • Stable Release.

example/lib/main.dart

import 'package:flutter/material.dart';
import 'rabbit_converter.dart';

void main() => runApp(MyApp());

class MyApp extends StatelessWidget {
  // This widget is the root of your application.
  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      title: 'Flutter Demo',
      theme: ThemeData(
        // This is the theme of your application.
        //
        // Try running your application with "flutter run". You'll see the
        // application has a blue toolbar. Then, without quitting the app, try
        // changing the primarySwatch below to Colors.green and then invoke
        // "hot reload" (press "r" in the console where you ran "flutter run",
        // or simply save your changes to "hot reload" in a Flutter IDE).
        // Notice that the counter didn't reset back to zero; the application
        // is not restarted.
        primarySwatch: Colors.blue,
      ),
      home: MyHomePage(title: 'Flutter Rabbit Converter Example'),
    );
  }
}

class MyHomePage extends StatefulWidget {
  MyHomePage({Key key, this.title}) : super(key: key);

  // This widget is the home page of your application. It is stateful, meaning
  // that it has a State object (defined below) that contains fields that affect
  // how it looks.

  // This class is the configuration for the state. It holds the values (in this
  // case the title) provided by the parent (in this case the App widget) and
  // used by the build method of the State. Fields in a Widget subclass are
  // always marked "final".

  final String title;

  @override
  _MyHomePageState createState() => _MyHomePageState();
}

class _MyHomePageState extends State<MyHomePage> {
  int _counter = 0;

  var formKey = GlobalKey<FormState>();

  var typedString = '';

  @override
  Widget build(BuildContext context) {

    var controller = TextEditingController();
    


    return Scaffold(
      appBar: AppBar(

        title: Text(widget.title),
      ),
      body: Form(
        key: formKey,
        child: Column(
          children: <Widget>[
            Container(
              margin: EdgeInsets.all(16.0),
              child: TextFormField(
                controller: controller,
                decoration: InputDecoration(
                  border: OutlineInputBorder(),
                  hintText: 'Say Something',
                ),
                validator: (value){
                  if (value != null){
                    /// This gets the value from the textfield and converts it, stored it in the var "typedString".
                    typedString = Rabbit.uni2zg(value);
                    return null;
                  }
                  return null;
                },


              ),
            ),
            Container(
              child: Text(
                typedString,
              ),
            )
          ],
        ),
      ),

      floatingActionButton: FloatingActionButton.extended(
        onPressed: (){
          if (formKey.currentState.validate()) {
            formKey.currentState.save();
            setState(() {

            });
          }
        },
        label: Text('Convert'),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  rabbit_converter: ^1.0.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:rabbit_converter/rabbit_converter.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
69
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
84
Learn more about scoring.

We analyzed this package on Jul 12, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.14
  • Flutter: 1.17.5

Analysis suggestions

Package not compatible with SDK dart

Because:

  • rabbit_converter that is a package requiring null.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.2
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
Dev dependencies
flutter_test