qz_ui_kit 0.0.9
qz_ui_kit: ^0.0.9 copied to clipboard

Flutter Android iOS

A new Flutter project.

0
likes
50 / 110
pub points
20 %
popularity

We analyzed this package on Feb 28, 2021, and awarded it 50 pub points (of a possible 110):

Follow Dart file conventions
0 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

0/5 points: Provide a valid README.md

`README.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of README.md in your package should primarily contain characters used in English.

0/5 points: Provide a valid CHANGELOG.md

`CHANGELOG.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of CHANGELOG.md in your package should primarily contain characters used in English.

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 65 out of 364 API elements (17.9 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:qz_ui_kit/qz_ui_kit.dart that imports:
  • package:qz_ui_kit/helper/scan_page.dart that imports:
  • package:flutter_qr_reader/qrcode_reader_view.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 26 issues. Showing the first 2:

INFO: Name non-constant identifiers using lowerCamelCase.

lib/http/log_util.dart:5:17

  ╷
5 │   static String TAG = _TAG_DEF;
  │                 ^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/http/log_util.dart

INFO: The value of the local variable 'width' isn't used.

lib/widgets/dialog.dart:219:11

    ╷
219 │     final width = size.width;
    │           ^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/widgets/dialog.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
bot_toast^3.0.53.0.54.0.0+1
city_pickers^0.2.00.2.00.2.0
connectivity^2.0.22.0.23.0.0
dio^3.0.103.0.103.0.10
extended_image^1.5.01.6.01.6.0
flutterflutter0.0.00.0.0
flutter_picker^1.1.51.1.51.1.5
flutter_qr_reader^1.0.31.0.31.0.3
flutter_screenutil^4.0.2+54.0.3+24.0.3+2
flutter_spinkit^4.1.2+14.1.2+14.1.2+1
image_picker^0.6.7+210.6.7+220.7.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.31.1.0
charcode-1.1.31.2.0
collection-1.15.0-nullsafety.31.15.0
connectivity_for_web-0.3.1+40.3.1+4
connectivity_macos-0.1.0+70.2.0
connectivity_platform_interface-1.0.62.0.0
convert-2.1.13.0.0
crypto-2.1.53.0.0
extended_image_library-0.3.10.3.1
ffi-0.1.31.0.0
file-5.2.16.1.0
flutter_plugin_android_lifecycle-1.0.112.0.0
flutter_web_plugins-0.0.00.0.0
http-0.12.20.13.0
http_client_helper-0.2.10.3.2
http_parser-3.1.44.0.0
image_picker_platform_interface-1.1.62.0.0
intl-0.16.10.17.0
lpinyin-1.1.11.1.1
meta-1.3.0-nullsafety.31.3.0
path-1.7.01.8.0
path_provider-1.6.272.0.0
path_provider_linux-0.0.1+22.0.0
path_provider_macos-0.0.4+82.0.0
path_provider_platform_interface-1.0.42.0.0
path_provider_windows-0.0.4+32.0.0
pedantic-1.9.21.10.0
platform-2.2.13.0.0
plugin_platform_interface-1.0.32.0.0
process-3.0.134.1.0
sky_engine-0.0.990.0.99
source_span-1.7.01.8.1
string_scanner-1.0.51.1.0
term_glyph-1.1.01.2.0
typed_data-1.3.0-nullsafety.31.3.0
vector_math-2.1.0-nullsafety.32.1.0
win32-1.7.4+12.0.0
xdg_directories-0.1.20.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^3.0.5` on bot_toast does not support the latest published version `4.0.0+1`

pubspec.yaml:20:14

   ╷
20 │   bot_toast: ^3.0.5
   │              ^^^^^^
   ╵
The constraint `^2.0.2` on connectivity does not support the latest published version `3.0.0`

pubspec.yaml:21:17

   ╷
21 │   connectivity: ^2.0.2
   │                 ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.14.10, Flutter 1.22.6, Dart 2.10.5.