quotable 0.0.1 copy "quotable: ^0.0.1" to clipboard
quotable: ^0.0.1 copied to clipboard

A simple API Wrapper for https://github.com/lukePeavey/quotable

0
likes
110/ 140
pub points
13%
popularity

We analyzed this package 16 hours ago, and awarded it 110 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

12 out of 78 API elements (15.4 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: quotable.Authors, quotable.Authors.Authors, quotable.Authors.bio, quotable.Authors.dateAdded, quotable.Authors.dateModified.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 7 issues. Showing the first 2:

INFO: The variable name 'VERSION' isn't a lowerCamelCase identifier.

lib/quotable.dart:14:14

   ╷
14 │ final String VERSION = '0.0.1';
   │              ^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/quotable.dart

INFO: Dangling library doc comment.

lib/src/functions.dart:1:1

  ╷
1 │ /// MAIN FUNCTIONS FOR THE LIBRARY
  │ ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/functions.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
http ^0.13.3 0.13.6 1.2.1
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
collection - 1.18.0 1.18.0
http_parser - 4.0.2 4.0.2
meta - 1.15.0 1.15.0
path - 1.9.0 1.9.0
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.13.3` on http does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.4.1.

Check the analysis log for details.

0
likes
110
pub points
13%
popularity

Publisher

verified publisherjoshueabance.cf

A simple API Wrapper for https://github.com/lukePeavey/quotable

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

http

More

Packages that depend on quotable