quidpay 0.4.0+1
quidpay: ^0.4.0+1

Dart native
Flutter Android iOS

Quidpay payment SDK for Dart

0
likes
50 / 110
pub points
0 %
popularity

We analyzed this package on Dec 1, 2020, and awarded it 50 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 37 out of 944 API elements (3.9 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:quidpay/quidpay.dart that imports:
  • package:quidpay/src/validate.dart that imports:
  • package:quidpay/src/utils/response.dart that imports:
  • package:quidpay/src/utils/exceptions.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 5 issues. Showing the first 2:

INFO: Avoid const keyword.

lib/src/models/serializers.dart:19:17

   ╷
19 │   @SerializersFor(const [
   │ ┌─────────────────^
20 │ │   Result,
21 │ │   VerifyResult,
22 │ │   Card,
23 │ │   ValidateResult,
24 │ │   Bank,
25 │ │   Metadata,
26 │ │ ])
   │ └─^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/models/serializers.dart

INFO: 'onError' is deprecated and shouldn't be used. Use runZonedGuarded instead.

lib/src/utils/local_server.dart:52:7

   ╷
52 │       onError: (dynamic e) {
   │       ^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/utils/local_server.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
built_collection^4.2.04.3.24.3.2
built_value^6.4.06.8.27.1.0
convert^2.1.12.1.12.1.1
crypto^2.0.62.1.52.1.5
http^0.12.00.12.20.12.2
meta^1.1.71.2.41.2.4
tripledes^2.1.02.1.02.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
analyzer-0.38.50.41.1
analyzer_plugin-0.2.10.3.0
args-1.6.01.6.0
async-2.4.22.4.2
build-1.5.11.5.1
build_config-0.4.30.4.3
charcode-1.1.31.1.3
checked_yaml-1.0.21.0.2
collection-1.14.131.14.13
csslib-0.16.20.16.2
dart_style-1.3.31.3.10
file-5.2.15.2.1
fixnum-0.10.110.10.11
front_end-0.1.270.1.29
glob-1.2.01.2.0
html-0.14.0+40.14.0+4
http_parser-3.1.43.1.4
intl-0.16.10.16.1
js-0.6.20.6.2
json_annotation-3.1.13.1.1
kernel-0.3.270.3.29
logging-0.11.40.11.4
matcher-0.12.90.12.9
node_interop-1.2.11.2.1
node_io-1.2.01.2.0
package_config-1.9.31.9.3
path-1.7.01.7.0
pub_semver-1.4.41.4.4
pubspec_parse-0.1.50.1.5
quiver-2.1.52.1.5
source_gen-0.9.4+60.9.8
source_span-1.7.01.7.0
stack_trace-1.9.61.9.6
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0
watcher-0.9.7+150.9.7+15
yaml-2.2.12.2.1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^6.4.0` on built_value does not support the latest published version `7.1.0`

pubspec.yaml:14:16

   ╷
14 │   built_value: ^6.4.0
   │                ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs