quidpay 0.4.0+1

  • Readme
  • Changelog
  • Installing
  • 44

💳 Quidpay Dart SDK #

Build Status - Travis codecov pub package

🎖 Installing #

dependencies:
  quidpay: "^0.1.0"

⚡️ Import #

import 'package:quidpay/quidpay.dart';

ChangeLog for Quidpay SDK #

Quidpay

0.1.0 #

  • Initial release

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  quidpay: ^0.4.0+1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:quidpay/quidpay.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
44
Learn more about scoring.

We analyzed this package on Jul 2, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.9+1

Analysis suggestions

Package not compatible with runtime flutter-web of web

Because of the import of dart:io via the import chain package:quidpay/quidpay.dart->package:quidpay/src/validate.dart->package:quidpay/src/utils/response.dart->package:quidpay/src/utils/exceptions.dart->dart:io

Package not compatible with runtime web

Because of the import of dart:io via the import chain package:quidpay/quidpay.dart->package:quidpay/src/validate.dart->package:quidpay/src/utils/response.dart->package:quidpay/src/utils/exceptions.dart->dart:io

Health suggestions

Fix lib/src/models/serializers.dart. (-0.50 points)

Analysis of lib/src/models/serializers.dart reported 1 hint:

line 19 col 17: Avoid const keyword.

Format lib/src/constants/strings.dart.

Run dartfmt to format lib/src/constants/strings.dart.

Format lib/src/utils/exceptions.dart.

Run dartfmt to format lib/src/utils/exceptions.dart.

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (built_value).

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example.

None of the files in the package's example/ directory matches known example patterns.

Common filename patterns include main.dart, example.dart, and quidpay.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
built_collection ^4.2.0 4.3.2
built_value ^6.4.0 6.8.2 7.1.0
convert ^2.1.1 2.1.1
crypto ^2.0.6 2.1.5
http ^0.12.0 0.12.1
meta ^1.1.7 1.1.8 1.2.0
tripledes ^2.1.0 2.1.0
Transitive dependencies
analyzer 0.38.5 0.39.11
analyzer_plugin 0.2.1 0.2.4
args 1.6.0
async 2.4.1
build 1.3.0
build_config 0.4.2
charcode 1.1.3
checked_yaml 1.0.2
collection 1.14.13
csslib 0.16.1
dart_style 1.3.3 1.3.6
fixnum 0.10.11
front_end 0.1.27 0.1.29
glob 1.2.0
html 0.14.0+3
http_parser 3.1.4
js 0.6.2
json_annotation 3.0.1
kernel 0.3.27 0.3.29
logging 0.11.4
matcher 0.12.8
node_interop 1.1.1
node_io 1.1.1
package_config 1.9.3
path 1.7.0
pub_semver 1.4.4
pubspec_parse 0.1.5
quiver 2.1.3
source_gen 0.9.4+6 0.9.5
source_span 1.7.0
stack_trace 1.9.5
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.2.0
watcher 0.9.7+15
yaml 2.2.1
Dev dependencies
build_runner ^1.3.1
built_value_generator ^6.4.0 6.8.2 7.1.0
pedantic ^1.4.0 1.9.0 1.9.1
test ^1.0.0
test_coverage ^0.2.0