quickpass_yidun_flutter 1.0.9
quickpass_yidun_flutter: ^1.0.9 copied to clipboard

A new Flutter plugin for quichlogin.

4
likes
60/ 130
pub points
60%
popularity

We analyzed this package on Sep 27, 2021, and awarded it 60 pub points (of a possible 130):

Follow Dart file conventions
0 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://support.dun.163.com/documents/287305921855672320?docId=289905327964606464 was unreachable.

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

0/5 points: Provide a valid README.md

`README.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of README.md in your package should primarily contain characters used in English.

0/5 points: Provide a valid CHANGELOG.md

`CHANGELOG.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of CHANGELOG.md in your package should primarily contain characters used in English.

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 15 API elements (6.7 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:quickpass_yidun_flutter/quickpass_flutter_plugin.dart that declares support for platforms: Android, iOS.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/quickpass_flutter_plugin.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
modal_progress_hud^0.1.30.1.30.1.3
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
collection-1.15.01.15.0
meta-1.7.01.7.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Null safety support has one or more issues.

Package is not null safe

Because:

  • quickpass_yidun_flutter that depends on:
  • modal_progress_hud that doesn't opt in to null safety
For more information

Try running dart pub outdated --mode=null-safety. Be sure to read the migration guide.

Analysed with Pana 0.21.1+1, Flutter 2.5.0, Dart 2.14.0.

4
likes
60
pub points
60%
popularity

A new Flutter plugin for quichlogin.

Homepage

Documentation

API reference

License

unknown (LICENSE)

Dependencies

flutter, modal_progress_hud

More

Packages that depend on quickpass_yidun_flutter