quds_mysql 1.0.1+2 copy "quds_mysql: ^1.0.1+2" to clipboard
quds_mysql: ^1.0.1+2 copied to clipboard

An expansion package that simplifies creating databases and tables, crud operations, queries with modelization using mysql1

4
likes
130/ 140
pub points
0%
popularity

We analyzed this package 4 days ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

261 out of 292 API elements (89.4 %) have documentation comments.

Some symbols that are missing documentation: quds_mysql.DbHelper.characterSet, quds_mysql.DbHelper.dbPassword, quds_mysql.DbHelper.dbUser, quds_mysql.DbHelper.host, quds_mysql.DbHelper.maxPacketSize.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:quds_mysql/quds_mysql.dart that imports:
  • package:mysql1/mysql1.dart that imports:
  • package:mysql1/src/results/row.dart that imports:
  • package:mysql1/src/buffer.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
mysql1 ^0.19.2 0.19.2 0.20.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
collection - 1.18.0 1.18.0
crypto - 3.0.3 3.0.3
logging - 1.2.0 1.2.0
meta - 1.15.0 1.15.0
path - 1.9.0 1.9.0
pool - 1.5.1 1.5.1
stack_trace - 1.11.1 1.11.1
typed_data - 1.3.2 1.3.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.19.2` on mysql1 does not support the stable version `0.20.0`.

Try running dart pub upgrade --major-versions mysql1 to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.4.0.

Check the analysis log for details.

4
likes
130
pub points
0%
popularity

Publisher

verified publisherquds.cc

An expansion package that simplifies creating databases and tables, crud operations, queries with modelization using mysql1

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

mysql1

More

Packages that depend on quds_mysql