qr_flutter 4.1.0 copy "qr_flutter: ^4.1.0" to clipboard
qr_flutter: ^4.1.0 copied to clipboard

QR.Flutter is a Flutter library for simple and fast QR code rendering via a Widget or custom painter.

example/lib/main.dart

/*
 * QR.Flutter
 * Copyright (c) 2019 the QR.Flutter authors.
 * See LICENSE for distribution and usage details.
 */

import 'package:flutter/material.dart';
import 'package:flutter/services.dart';

import 'main_screen.dart';

void main() => runApp(ExampleApp());

/// The example application class
class ExampleApp extends StatelessWidget {
  // This widget is the root of your application.
  @override
  Widget build(BuildContext context) {
    SystemChrome.setSystemUIOverlayStyle(
      const SystemUiOverlayStyle(
        statusBarColor: Colors.white,
        statusBarIconBrightness: Brightness.dark,
        systemNavigationBarColor: Colors.white,
        systemNavigationBarIconBrightness: Brightness.dark,
      ),
    );
    return MaterialApp(
      title: 'QR.Flutter',
      theme: ThemeData.light(),
      debugShowCheckedModeBanner: false,
      home: MainScreen(),
    );
  }
}
1986
likes
150
pub points
100%
popularity

Publisher

verified publishertheyakka.com

QR.Flutter is a Flutter library for simple and fast QR code rendering via a Widget or custom painter.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (license)

Dependencies

flutter, qr

More

Packages that depend on qr_flutter