qiscus_sdk 0.1.0
qiscus_sdk: ^0.1.0 copied to clipboard

Qiscus Chat SDK plugin for iOS and Android

0
likes
50/ 130
pub points
0%
popularity

We analyzed this package 2 days ago, and awarded it 50 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 13 out of 196 API elements (6.6 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
0 / 20

0/20 points: Supports 1 of 3 possible platforms (iOS, Android, Web)

Found 7 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `iOS`.

Because:

  • package:qiscus_sdk/qiscus_sdk.dart that declares support for platforms: Android.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 5 issues. Showing the first 2:

lib/src/chat_sdk.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/src/model/qiscus_account.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
data_connection_checker^0.3.40.3.40.3.4
equatable^1.1.11.2.62.0.3
flutterflutter0.0.00.0.0
json_annotation^3.0.13.1.14.4.0
rxdart^0.23.10.23.10.27.3
tuple^1.0.31.0.32.0.0
uuid^2.0.42.2.23.0.5
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
convert-2.1.13.0.1
crypto-2.1.53.0.1
matcher-0.12.110.12.11
meta-1.7.01.7.0
path-1.8.01.8.0
quiver-2.1.53.0.1+1
sky_engine-0.0.990.0.99
stack_trace-1.10.01.10.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 5 issues. Showing the first 2:

The constraint `^1.1.1` on equatable does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions equatable to update the constraint.

The constraint `^3.0.1` on json_annotation does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions json_annotation to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.