pwa 0.2.0
pwa: ^0.2.0 copied to clipboard

Progressive Web App library

15
likes
60 / 130
pub points
77 %
popularity

We analyzed this package on Jun 24, 2021, and awarded it 60 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 73 out of 81 API elements (90.1 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime native

Because:

  • package:pwa/client.dart that imports:
  • package:service_worker/window.dart that imports:
  • package:service_worker/src/service_worker_api.dart that imports:
  • package:service_worker/src/js_facade/service_worker_api.dart that imports:
  • package:service_worker/src/js_facade/promise.dart that imports:
  • package:js/js.dart that imports:
  • dart:js
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

bin/pwa.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
args^1.4.01.6.02.1.1
dart_style>=0.2.16 <2.0.01.3.122.0.1
glob^1.1.31.2.02.0.1
service_worker>=0.1.0 <0.3.00.2.40.2.4
yaml^2.1.122.2.13.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-14.0.022.0.0
analyzer-0.41.21.7.1
async-2.7.02.7.0
charcode-1.3.11.3.1
cli_util-0.3.10.3.1
clock-1.1.01.1.0
collection-1.15.01.15.0
convert-3.0.03.0.0
crypto-3.0.13.0.1
file-5.2.16.1.2
intl-0.17.00.17.0
js-0.6.30.6.3
meta-1.4.01.4.0
node_interop-1.2.12.0.2
node_io-1.2.02.1.0
package_config-1.9.32.0.0
path-1.8.01.8.0
pedantic-1.11.11.11.1
pub_semver-2.0.02.0.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
watcher-1.0.01.0.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^1.4.0` on args does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions args to update the constraint.

The constraint `>=0.2.16 <2.0.0` on dart_style does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions dart_style to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.0.0-dev <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.18.2, Dart 2.13.3.

15
likes
60
pub points
77%
popularity

Publisher

Unknown

Progressive Web App library

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

args, dart_style, glob, service_worker, yaml

More

Packages that depend on pwa