pug 0.0.3

  • Readme
  • Changelog
  • Example
  • Installing
  • 48

A library for Dart developers.

Created from templates made available by Stagehand under a BSD-style license.

Usage #

A simple usage example:

import 'package:pug/pug.dart';

main() {
  var awesome = new Awesome();
}

Features and bugs #

Please file feature requests and bugs at the issue tracker.

1.0.0 #

  • Initial version, created by Stagehand

example/pug_example.dart

import 'package:pug/pug.dart';

main() {
  var awesome = Awesome();
  print('awesome: ${awesome.isAwesome}');
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  pug: ^0.0.3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:pug/pug.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
8
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
72
Overall:
Weighted score of the above. [more]
48
Learn more about scoring.

We analyzed this package on Dec 9, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.1
  • pana: 0.12.21

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (analyzer).

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

The package description is too short. (-8 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
analyzer ^0.36.0 0.36.4 0.39.2+1
args ^1.5.1 1.5.2
collection ^1.14.11 1.14.12
crypto ^2.0.6 2.1.4
html ^0.14.0+1 0.14.0+3
http_parser ^3.1.3 3.1.3
logging ^0.11.3+2 0.11.3+2
markdown ^2.0.2 2.1.3
mustache ^1.1.1 1.1.1
package_config ^1.0.5 1.1.0
path ^1.6.2 1.6.4
process ^3.0.9 3.0.12
pub_semver ^1.4.2 1.4.2
quiver ^2.0.3 2.1.2+1
resource ^2.1.5 2.1.6
stack_trace ^1.9.3 1.9.3
yaml ^2.1.15 2.2.0
Transitive dependencies
async 2.4.0
charcode 1.1.2
convert 2.1.1
csslib 0.16.1
file 5.1.0
front_end 0.1.19 0.1.29
intl 0.16.0
js 0.6.1+1
kernel 0.3.19 0.3.29
matcher 0.12.6
node_interop 1.0.3
node_io 1.0.1+2
platform 2.2.1
source_span 1.5.5
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
watcher 0.9.7+13
Dev dependencies
build any
build_runner any
build_version any
coverage any
dhttpd any
glob any 1.2.0
grinder any
http any
io any
meta any 1.1.8
pedantic any 1.9.0
test any