pub_cache 0.3.1
pub_cache: ^0.3.1 copied to clipboard

A library to reflect on the local pub cache.

2
likes
95 / 130
pub points
85 %
popularity

We analyzed this package on Jun 23, 2021, and awarded it 95 pub points (of a possible 130):

Follow Dart file conventions
5 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 image link is insecure.

README.md:3:58

  ╷
3 │ <p><a href="https://pub.dartlang.org/packages/pub_cache"><img src="http://img.shields.io/pub/v/pub_cache.svg" alt="pub package" /></a>
  │                                                          ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 21 out of 27 API elements (77.8 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:pub_cache/pub_cache.dart that imports:
  • package:pub_cache/src/impl.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
path^1.8.01.8.01.8.0
pub_semver^2.0.02.0.02.0.0
yaml^3.0.03.1.03.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.3.11.3.1
collection-1.15.01.15.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.18.2, Dart 2.13.3.

2
likes
95
pub points
85%
popularity

Publisher

Unknown

A library to reflect on the local pub cache.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

path, pub_semver, yaml

More

Packages that depend on pub_cache