protect 0.0.2
protect: ^0.0.2 copied to clipboard

Protect protects excel files with password and also helps to decrypt the password protected excel files

2
likes
80 / 130
pub points
18 %
popularity

We analyzed this package on Jul 28, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 8 out of 43 API elements (18.6 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:protect/protect.dart that imports:
  • package:aes_crypt/aes_crypt.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
aes_crypt^0.1.10.1.10.1.1
crypto^2.1.52.1.53.0.1
utf^0.9.0+50.9.0+50.9.0+5
xml_parser^0.1.20.1.21.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.3.11.3.1
collection-1.15.01.15.0
convert-2.1.13.0.1
html_character_entities-0.1.2+41.0.0+1
http-0.12.20.13.3
http_parser-3.1.44.0.0
meta-1.7.01.7.0
path-1.8.01.8.0
pedantic-1.11.11.11.1
recursive_regex-0.1.3+21.0.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.1.5` on crypto does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions crypto to update the constraint.

The constraint `^0.1.2` on xml_parser does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions xml_parser to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.19.0, Dart 2.13.4.

2
likes
80
pub points
18%
popularity

Protect protects excel files with password and also helps to decrypt the password protected excel files

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

aes_crypt, crypto, utf, xml_parser

More

Packages that depend on protect