process 5.0.2 copy "process: ^5.0.2" to clipboard
process: ^5.0.2 copied to clipboard

A pluggable, mockable process invocation abstraction for Dart.

33
likes
130/ 140
pub points
100%
popularity

We analyzed this package 6 days ago, and awarded it 130 pub points (of a possible 140):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/flutter/flutter/issues?q=is%3Aissue+is%3Aopen+label%3A%22p%3A+process%22 was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

30 out of 31 API elements (96.8 %) have documentation comments.

Some symbols that are missing documentation: process.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:process/process.dart that imports:
  • package:process/src/interface/process_wrapper.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
file >=6.0.0 <8.0.0 7.0.0 7.0.0
path ^1.8.0 1.9.0 1.9.0
platform ^3.0.0 3.1.4 3.1.4
Transitive dependencies
Package Constraint Compatible Latest
meta - 1.15.0 1.15.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.4.0.

Check the analysis log for details.

33
likes
130
pub points
100%
popularity

Publisher

verified publisherflutter.dev

A pluggable, mockable process invocation abstraction for Dart.

Repository (GitHub)
View/report issues
Contributing

Topics

#process

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

file, path, platform

More

Packages that depend on process