platform_settings_ui 0.1.2 copy "platform_settings_ui: ^0.1.2" to clipboard
platform_settings_ui: ^0.1.2 copied to clipboard

Easily create settings pages with iOS 15 and Android 11 norms.

12
likes
70/ 140
pub points
62%
popularity

We analyzed this package 5 days ago, and awarded it 70 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

17 out of 182 API elements (9.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: edit_type_enum, edit_type_enum.EditType, edit_type_enum.EditType.EditType, list_edit_tile, list_edit_tile.ListEditTile.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:platform_settings_ui/platform_settings_ui.dart that imports:
  • package:platform_settings_ui/edits_types/list_edit_type_view.dart that imports:
  • package:platform_settings_ui/settings_section/settings_section.dart that imports:
  • dart:io
failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

Found 17 issues. Showing the first 2:

ERROR: The named parameter 'isPhoneNumber' isn't defined.

lib/edits_types/text_edit_type.dart:33:9

   ╷
33 │         isPhoneNumber: true,
   │         ^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/edits_types/text_edit_type.dart

ERROR: The named parameter 'placeHolder' isn't defined.

lib/edits_types/text_edit_type.dart:34:9

   ╷
34 │         placeHolder: subTitle,
   │         ^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/edits_types/text_edit_type.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
more_widgets ^3.0.6 3.1.6 3.1.6
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.

12
likes
70
pub points
62%
popularity

Publisher

unverified uploader

Easily create settings pages with iOS 15 and Android 11 norms.

Repository (GitHub)
View/report issues

Documentation

API reference

License

unknown (LICENSE)

Dependencies

flutter, more_widgets

More

Packages that depend on platform_settings_ui