pip_services3_components 1.2.4 copy "pip_services3_components: ^1.2.4" to clipboard
pip_services3_components: ^1.2.4 copied to clipboard

Components patterns for Pip.Services in Dart. This framework is part of the [Pip.Services](https://github.com/pip-services/pip-services) project.

1
likes
105/ 140
pub points
2%
popularity

We analyzed this package 2 days ago, and awarded it 105 pub points (of a possible 140):

failed
Follow Dart file conventions
25 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:2:33

  ╷
2 │ <p>This module is a part of the <a href="http://pipservices.org">Pip.Services</a> polyglot microservices toolkit.</p>
  │                                 ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

544 out of 614 API elements (88.6 %) have documentation comments.

Some symbols that are missing documentation: pip_services3_components, pip_services3_components.CachedLogger.cache, pip_services3_components.CachedLogger.interval, pip_services3_components.CachedLogger.lastDumpTime, pip_services3_components.CachedLogger.maxCacheSize.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Android

Because:

  • package:pip_services3_components/pip_services3_components.dart that imports:
  • package:pip_services3_components/src/Component.dart that imports:
  • package:pip_services3_components/src/count/CompositeCounters.dart that imports:
  • package:pip_services3_commons/pip_services3_commons.dart that imports:
  • package:pip_services3_commons/src/validate/validate.dart that imports:
  • package:pip_services3_commons/src/validate/ProjectionParamsSchema.dart that imports:
  • package:pip_services3_commons/src/validate/ArraySchema.dart that imports:
  • package:pip_services3_commons/src/reflect/ObjectReader.dart that imports:
  • package:pip_services3_commons/src/reflect/PropertyReflector.dart that imports:
  • dart:mirrors
Package not compatible with platform iOS

Because:

  • package:pip_services3_components/pip_services3_components.dart that imports:
  • package:pip_services3_components/src/Component.dart that imports:
  • package:pip_services3_components/src/count/CompositeCounters.dart that imports:
  • package:pip_services3_commons/pip_services3_commons.dart that imports:
  • package:pip_services3_commons/src/validate/validate.dart that imports:
  • package:pip_services3_commons/src/validate/ProjectionParamsSchema.dart that imports:
  • package:pip_services3_commons/src/validate/ArraySchema.dart that imports:
  • package:pip_services3_commons/src/reflect/ObjectReader.dart that imports:
  • package:pip_services3_commons/src/reflect/PropertyReflector.dart that imports:
  • dart:mirrors
Package not compatible with platform Web

Because:

  • package:pip_services3_components/pip_services3_components.dart that imports:
  • package:pip_services3_components/src/Component.dart that imports:
  • package:pip_services3_components/src/count/CompositeCounters.dart that imports:
  • package:pip_services3_commons/pip_services3_commons.dart that imports:
  • package:pip_services3_commons/src/validate/validate.dart that imports:
  • package:pip_services3_commons/src/validate/ProjectionParamsSchema.dart that imports:
  • package:pip_services3_commons/src/validate/ArraySchema.dart that imports:
  • package:pip_services3_commons/src/reflect/ObjectReader.dart that imports:
  • package:pip_services3_commons/src/reflect/PropertyReflector.dart that imports:
  • dart:mirrors
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 124 issues. Showing the first 2:

WARNING: The operand can't be null, so the condition is always 'false'.

lib/src/build/Factory.dart:44:17

   ╷
44 │     if (factory == null) throw Exception('Factory cannot be null');
   │                 ^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/build/Factory.dart

WARNING: The operand can't be null, so the condition is always 'true'.

lib/src/count/CompositeCounters.dart:89:20

   ╷
89 │       if (callback != null) {
   │                    ^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/count/CompositeCounters.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
pip_services3_commons ^1.1.0 1.1.7 1.1.7
pip_services3_expressions ^1.0.0 1.0.1 1.0.1
sprintf ^6.0.0 6.0.2 7.0.0
yaml ^3.1.0 3.1.2 3.1.2
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 31.0.0 67.0.0
analyzer - 2.8.0 6.4.1
async - 2.11.0 2.11.0
cli_util - 0.3.5 0.4.1
collection - 1.18.0 1.18.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
file - 7.0.0 7.0.0
glob - 2.1.2 2.1.2
meta - 1.14.0 1.14.0
package_config - 2.1.0 2.1.0
path - 1.9.0 1.9.0
pub_semver - 2.1.4 2.1.4
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
uuid - 3.0.7 4.4.0
watcher - 1.1.0 1.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^6.0.0` on sprintf does not support the stable version `7.0.0`.

Try running dart pub upgrade --major-versions sprintf to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.3.3.

Check the analysis log for details.

1
likes
105
pub points
2%
popularity

Publisher

verified publisherentinco.com

Components patterns for Pip.Services in Dart. This framework is part of the [Pip.Services](https://github.com/pip-services/pip-services) project.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

pip_services3_commons, pip_services3_expressions, sprintf, yaml

More

Packages that depend on pip_services3_components