ping_view_widget 1.0.0 copy "ping_view_widget: ^1.0.0" to clipboard
ping_view_widget: ^1.0.0 copied to clipboard

A new Flutter package project.

3
likes
90/ 140
pub points
0%
popularity

We analyzed this package 3 days ago, and awarded it 90 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Homepage URL doesn't exist.

At the time of the analysis https://unicodelabs.in was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

2 out of 24 API elements (8.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: extension, extension.CanvasExtension, extension.CanvasExtension.drawGlowingCircle, extension.CanvasExtension.drawGlowingPath, extension.PathExtension.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

WARNING: The value of the local variable 'themeData' isn't used.

lib/ping_view_widget.dart:85:15

   ╷
85 │     ThemeData themeData = Theme.of(context);
   │               ^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/ping_view_widget.dart

INFO: The import of 'package:flutter/widgets.dart' is unnecessary because all of the used elements are also provided by the import of 'package:flutter/material.dart'.

lib/ping_view_widget.dart:5:8

  ╷
5 │ import 'package:flutter/widgets.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/ping_view_widget.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
path_drawing ^0.5.1 0.5.1+1 1.0.1
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
path_parsing - 0.2.1 1.0.1
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.5.1` on path_drawing does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions path_drawing to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

3
likes
90
pub points
0%
popularity

Publisher

verified publisherunicodelabs.in

A new Flutter package project.

Homepage

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

flutter, path_drawing

More

Packages that depend on ping_view_widget