permission_handler 9.2.0 copy "permission_handler: ^9.2.0" to clipboard
permission_handler: ^9.2.0 copied to clipboard

outdated

Permission plugin for Flutter. This plugin provides a cross-platform (iOS, Android) API to request and check permissions.

5132
likes
150/ 160
pub points
100%
popularity

We analyzed this package 25 hours ago, and awarded it 150 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

86 out of 87 API elements (98.9 %) have documentation comments.

Some symbols that are missing documentation: permission_handler.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows

These platforms are not supported:

Package does not support platform `Linux`.

Because:

  • package:permission_handler/permission_handler.dart that declares support for platforms: Android, iOS, Windows.
Package does not support platform `macOS`.

Because:

  • package:permission_handler/permission_handler.dart that declares support for platforms: Android, iOS, Windows.
Package does not support platform `Web`.

Because:

  • package:permission_handler/permission_handler.dart that declares support for platforms: Android, iOS, Windows.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
meta ^1.7.0 1.12.0 1.15.0
permission_handler_android ^9.0.2 9.0.2+1 12.0.7
permission_handler_apple ^9.0.2 9.1.4 9.4.5
permission_handler_platform_interface ^3.7.0 3.12.0 4.2.1
permission_handler_windows ^0.1.0 0.1.3 0.2.1
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
material_color_utilities - 0.8.0 0.12.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^9.0.2` on permission_handler_android does not support the stable version `10.0.0`.

Try running dart pub upgrade --major-versions permission_handler_android to update the constraint.

The constraint `^3.7.0` on permission_handler_platform_interface does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions permission_handler_platform_interface to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.9, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

5132
likes
150
pub points
100%
popularity

Publisher

verified publisherbaseflow.com

Permission plugin for Flutter. This plugin provides a cross-platform (iOS, Android) API to request and check permissions.

Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

License

MIT (license)

Dependencies

flutter, meta, permission_handler_android, permission_handler_apple, permission_handler_platform_interface, permission_handler_windows

More

Packages that depend on permission_handler