periodic 1.0.0+1 icon indicating copy to clipboard operation
periodic: ^1.0.0+1 copied to clipboard

A periodic widget (and dialog) to choose a recurring pattern.

1
likes
100/ 130
pub points
18%
popularity

We analyzed this package 34 hours ago, and awarded it 100 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 69 out of 81 API elements (85.2 %) have documentation comments.
icon indicating section status
Support multiple platforms
20 / 20icon to trigger folding of the section

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
auto_size_text^2.1.02.1.03.0.0
customtogglebuttons^0.0.50.0.50.0.5
flutterflutter0.0.00.0.0
flutter_hooks^0.15.00.15.00.18.2
freezed_annotation^0.12.00.12.01.1.0
group_radio_button^1.0.11.1.01.1.0
hooks_riverpod^0.12.20.12.41.0.3
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.01.2.0
collection-1.15.01.15.0
flutter_riverpod-0.12.41.0.3
json_annotation-3.1.14.4.0
meta-1.7.01.7.0
riverpod-0.12.41.0.3
sky_engine-0.0.990.0.99
state_notifier-0.7.2+10.7.2+1
typed_data-1.3.01.3.0
vector_math-2.1.12.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^2.1.0` on auto_size_text does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions auto_size_text to update the constraint.

The constraint `^0.15.0` on flutter_hooks does not support the stable version `0.16.0`.

Try running dart pub upgrade --major-versions flutter_hooks to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Flutter 2.8.1, Dart 2.15.1.