pdf_render 1.4.7 copy "pdf_render: ^1.4.7" to clipboard
pdf_render: ^1.4.7 copied to clipboard

A plugin that provides you with intermediate PDF rendering APIs and easy-to-use Flutter Widgets.

199
likes
120/ 140
pub points
98%
popularity

We analyzed this package 7 days ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

135 out of 162 API elements (83.3 %) have documentation comments.

Some symbols that are missing documentation: pdf_render, pdf_render.PdfDocument.dispose, pdf_render.PdfPageImage, pdf_render.PdfPageImage.PdfPageImage, pdf_render.PdfPageImage.createImageDetached.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 4 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ macOS
  • ✓ Web

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:pdf_render/pdf_render.dart that declares support for platforms: Android, iOS, macOS, Web.
Package does not support platform `Linux`.

Because:

  • package:pdf_render/pdf_render.dart that declares support for platforms: Android, iOS, macOS, Web.
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 10 issues. Showing the first 2:

WARNING: The parameter type of '==' operators should be non-nullable.

lib/src/interfaces/pdf_render.dart:60:17

   ╷
60 │   bool operator ==(dynamic other);
   │                 ^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/interfaces/pdf_render.dart

WARNING: The parameter type of '==' operators should be non-nullable.

lib/src/interfaces/pdf_render.dart:108:17

    ╷
108 │   bool operator ==(dynamic other) =>
    │                 ^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/interfaces/pdf_render.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
collection ^1.18.0 1.18.0 1.18.0
flutter flutter 0.0.0 0.0.0
flutter_web_plugins flutter 0.0.0 0.0.0
js ^0.7.1 0.7.1 0.7.1
plugin_platform_interface ^2.1.8 2.1.8 2.1.8
vector_math ^2.1.4 2.1.4 2.1.4
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.

199
likes
120
pub points
98%
popularity

Publisher

verified publisherespresso3389.jp

A plugin that provides you with intermediate PDF rendering APIs and easy-to-use Flutter Widgets.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

collection, flutter, flutter_web_plugins, js, plugin_platform_interface, vector_math

More

Packages that depend on pdf_render