payment_flutter 0.1.0 copy "payment_flutter: ^0.1.0" to clipboard
payment_flutter: ^0.1.0 copied to clipboard

A flutter plug-in for the native Payment library (Android and iOS).

0
likes
130/ 160
pub points
21%
popularity

We analyzed this package 36 hours ago, and awarded it 130 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Repository URL doesn't exist.

At the time of the analysis https://git.teko.vn/sale-channels/mobile-lab/terra-platform/minerva-flutter was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

2 out of 152 API elements (1.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

To highlight public API members missing documentation consider enabling the public_member_api_docs lint.

Some symbols that are missing documentation: main_method, main_method.MainMethod, main_method.MainMethod.amount, main_method.MainMethod.toFlutterMainMethod, main_method.MainMethodAll.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:payment_flutter/payment.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:payment_flutter/payment.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:payment_flutter/payment.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:payment_flutter/payment.dart that declares support for platforms: Android, iOS.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 9 issues. Showing the first 2:

INFO: The import of 'package:flutter/foundation.dart' is unnecessary because all of the used elements are also provided by the import of 'package:flutter/services.dart'.

lib/src/payment_api.dart:8:8

  ╷
8 │ import 'package:flutter/foundation.dart' show WriteBuffer, ReadBuffer;
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/payment_api.dart

lib/payment.dart doesn't match the Dart formatter.

To format your files run: dart format .

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
json_annotation ^4.5.0 4.9.0 4.9.0
json_serializable ^6.2.0 6.8.0 6.8.0
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 67.0.0 72.0.0
analyzer - 6.4.1 6.7.0
args - 2.5.0 2.5.0
async - 2.11.0 2.11.0
build - 2.4.1 2.4.1
build_config - 1.1.1 1.1.1
characters - 1.3.0 1.3.0
checked_yaml - 2.0.3 2.0.3
collection - 1.18.0 1.19.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
dart_style - 2.3.6 2.3.6
file - 7.0.0 7.0.0
glob - 2.1.2 2.1.2
logging - 1.2.0 1.2.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
package_config - 2.1.0 2.1.0
path - 1.9.0 1.9.0
pub_semver - 2.1.4 2.1.4
pubspec_parse - 1.3.0 1.3.0
sky_engine - 0.0.99 0.0.99
source_gen - 1.5.0 1.5.0
source_helper - 1.3.4 1.3.4
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
watcher - 1.1.0 1.1.0
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

0
likes
130
pub points
21%
popularity

Publisher

unverified uploader

A flutter plug-in for the native Payment library (Android and iOS).

Repository

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

flutter, json_annotation, json_serializable

More

Packages that depend on payment_flutter