pay 2.0.0 copy "pay: ^2.0.0" to clipboard
pay: ^2.0.0 copied to clipboard

A plug-in to add support for payments on Flutter applications.

885
likes
140/ 140
pub points
98%
popularity

We analyzed this package 4 days ago, and awarded it 140 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

67 out of 77 API elements (87.0 %) have documentation comments.

Some symbols that are missing documentation: pay, pay.ButtonPlaceholder.child, pay.ButtonPlaceholder.margin, pay.PayButton.height, pay.PayButton.margin.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:pay/pay.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:pay/pay.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:pay/pay.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:pay/pay.dart that declares support for platforms: Android, iOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:pay/pay.dart that imports:
  • package:pay_ios/pay_ios.dart that declares support for platforms: iOS.
Package does not support platform `iOS`.

Because:

  • package:pay/pay.dart that imports:
  • package:pay_android/pay_android.dart that declares support for platforms: Android.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
flutter_localizations flutter 0.0.0 0.0.0
meta ^1.10.0 1.11.0 1.14.0
pay_android ^2.0.0 2.0.0 2.0.0
pay_ios ^1.0.11 1.0.11 1.0.11
pay_platform_interface ^1.0.4 1.0.4 1.0.4
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
intl - 0.18.1 0.19.0
material_color_utilities - 0.8.0 0.11.1
path - 1.9.0 1.9.0
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
vector_math - 2.1.4 2.1.4
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.